Subject: Reinstall postgresql on amazonEC2

From: Abhishek Gawand <[email-masked]>
Date: Thu, 3 Sep 2015 15:13:16 +0530

Hi,
I got problem like  ERROR: could not access file "$libdir/plpgsql": No such
file or directory.
Then I uninstall postgresql-9.4 from amazon EC2 and again install the
postgresql-9.4
from reference  *https://wiki.postgresql.org/wiki/YUM_Installation
<https://wiki.postgresql.org/wiki/YUM_Installation>.*

*But it does not work.In /usr/pgsql-9.4/bin got empty.*

*what should i do? Please help to fix it.*

Thanks & Regards,
Abhishek

---

From: Jeff Frost <[email-masked]>
Date: Thu, 3 Sep 2015 08:35:47 -0700

I’m afraid we need more to go on than that.

Could you share the output (copy/paste) of the yum commands?

> On Sep 3, 2015, at 2:43 AM, Abhishek Gawand <[email-masked]> wrote:
> 
> Hi,
> I got problem like  ERROR:  could not access file "$libdir/plpgsql": No such file or directory. 
> Then I uninstall postgresql-9.4 from amazon EC2 and again install the postgresql-9.4 from reference  https://wiki.postgresql.org/wiki/YUM_Installation <https://wiki.postgresql.org/wiki/YUM_Installation>.
> 
> But it does not work.In /usr/pgsql-9.4/bin got empty.
> 
> what should i do? Please help to fix it.

---

From: Craig Ringer <[email-masked]>
Date: Fri, 4 Sep 2015 11:18:34 +0800

Also, what platform/distro are you using for your EC2 instance?

The RPMs are mainly for Fedora, RHEL and CentOS. Amazon Linux isn't
officially supported as far as I know, nor would I recommend using it.

On 3 September 2015 at 23:35, Jeff Frost <[email-masked]> wrote:
> postgresql-9.4 from reference
> https://wiki.postgresql.org/wiki/YUM_Installation.
>

-- 
 Craig Ringer                   http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 09 Sep 2015 00:02:17 +0300

Hi,

We support Amazon Linux AMI 2015.03. If that is what you are using,
please tell us what you exactly did, and which packages you installed.

Regards,

-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Fri, 11 Sep 2015 11:46:57 +0300

Hi,

What is the status on this?

Regards, Devrim