Subject: pgaudit?

From: Bjørn T Johansen <[email-masked]>
Date: Fri, 19 Jan 2018 12:33:03 +0100

I found this, for RHEL 7: 

https://yum.postgresql.org/9.6/redhat/rhel-7-x86_64/repoview/pgaudit_96.html

But I can not find the same package for PostgreSQL 10, is this an oversight or intensional or am I just blind?

Regards,

BTJ

-- 
-----------------------------------------------------------------------------------------------
Bjørn T Johansen

[email-masked]
-----------------------------------------------------------------------------------------------
Someone wrote:
"I understand that if you play a Windows CD backwards you hear strange Satanic messages"
To which someone replied:
"It's even worse than that; play it forwards and it installs Windows"
-----------------------------------------------------------------------------------------------

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 19 Jan 2018 12:53:19 -0800

> But I can not find the same package for PostgreSQL 10, is this an oversight or intensional or am I just blind?

Well pgAudit supports 10:

https://github.com/pgaudit/pgaudit

"pgAudit versions relate to PostgreSQL major versions as follows:

     pgAudit v1.2.X is intended to support PostgreSQL 10.
"

I cannot find it either, so I have to believe this is an oversight. You 
might want to contact the Yum team directly:

https://yum.postgresql.org/contact.php

-- 
Adrian Klaver
[email-masked]

---

From: Bjørn T Johansen <[email-masked]>
Date: Sat, 20 Jan 2018 16:20:40 +0100

Hi.

Just wondering if this is an oversight or? :)

Regards,

BTJ

On Fri, 19 Jan 2018 12:53:19 -0800

---

From: Bjørn T Johansen <[email-masked]>
Date: Mon, 22 Jan 2018 09:21:45 +0100

> https://yum.postgresql.org/contact.php

Ok, I have sent them an email.. :)

BTJ

---

From: Devrim Gündüz <[email-masked]>
Date: Sun, 28 Jan 2018 13:13:32 +0000

Hi,

> Just wondering if this is an oversight or? :)

Added pgaudit12_10 to repo, which is pgaudit 1.2 for PostgreSQL 10.

Sorry for the delay.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Bjørn T Johansen <[email-masked]>
Date: Mon, 29 Jan 2018 08:47:51 +0100

On Sun, 28 Jan 2018 13:13:32 +0000

> Added pgaudit12_10 to repo, which is pgaudit 1.2 for PostgreSQL 10.

Thx... :)

BTJ

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 02 Feb 2018 00:46:24 +0100

Hi,

> https://yum.postgresql.org/contact.php

Just to follow this up: I pushed pgaudit12_10 (pgaudit 1.2 for PostgreSQL 10) 2
weeks ago.

Regards,

---

From: Simon Riggs <[email-masked]>
Date: Fri, 2 Feb 2018 00:43:14 +0000

> Just to follow this up: I pushed pgaudit12_10 (pgaudit 1.2 for PostgreSQL 10) 2

Very good, thank you Devrim.

-- 
Simon Riggs                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services