Subject: patch bug in 9.6 spec

From: Martín Marqués <[email-masked]>
Date: Thu, 6 Jul 2017 22:16:17 -0300

Hi,

I was making a custom build with a patch for 9.6 and found this which
seems to be a bug in the spec file of postgresql 9.6.3 src.rpm package:

%patch6 -p1
%if 0%{?rhel} && 0%{?rhel} <= 5
%patch7 -p1
%endif

Compilation passed because I'm using rhel7, but that patch doesn't exist
in the spec file, so if someone would have tried to compile it on rhel5
it would have failed.

I didn't do much digging on when it got there, but it seems it would be
good to remove it.

Regards,

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Sat, 22 Jul 2017 10:59:42 +0300

Hi Martin,

> I didn't do much digging on when it got there, but it seems it would be

I think you are using an older version of the spec file -- this is from 9.6.3-2 
changelog:

- Remove nonexistent Patch7 reference

I refactored the spec files recently, so please let me know if you see more
issues.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Martín Marqués <[email-masked]>
Date: Sat, 22 Jul 2017 07:20:36 -0300

Ok, I will check.

Thanks,