Subject: Missing barman-cli dependency for F26

From: Martin Marques <[email-masked]>
Date: Tue, 6 Feb 2018 18:21:26 -0300

Hi, it seems we have a broken dependency for barman-cli on Fedora 26

# dnf install barman-cli.noarch
Last metadata expiration check: 0:03:02 ago on Tue Feb  6 18:10:26 2018.
Error:
 Problem: conflicting requests
  - nothing provides python-argparse needed by barman-cli-1.2-1.f26.noarch

# dnf list barman-cli
Last metadata expiration check: 0:03:37 ago on Tue Feb  6 18:10:26 2018.
Available Packages
barman-cli.noarch               1.2-1.f26             pgdg10

I'll provide a fix for the spec file once I get the src.rpm :)

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services

---

From: Martín Marqués <[email-masked]>
Date: Tue, 6 Feb 2018 18:40:32 -0300

> I'll provide a fix for the spec file once I get the src.rpm :)

The requires line should look like this for Fedora 26 and later:

Requires:	python >= %{pybasever}, python < 3

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 21 Feb 2018 17:47:12 +0000

Hi,

> Requires:       python >= %{pybasever}, python < 3

Ok, will fix this tomorrow. Sorry for the delay. (I'll also update repmgr)

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Martín Marqués <[email-masked]>
Date: Wed, 21 Feb 2018 15:00:54 -0300

Thanks Devrim, I really appreciate it!

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 27 Mar 2018 23:50:34 +0100

Hi Martin,

> Requires:       python >= %{pybasever}, python < 3

Can you please send a full patch, along with conditionals for Fedora?

Thanks!

Regards,