Subject: pg_partman93

From: Martín Marqués <[email-masked]>
Date: Thu, 15 Oct 2015 18:35:53 -0300

Hi,

I was testing out a few things with partitioning and down the road I
installed pg_partman using the pgdg rpms.

Tests are on a 9.3 system so I installed the pg_partman93 package.

To my surprise, yum installed version 2.0.1 of pg_partman which is
compatible with PostgreSQL 9.4+, not with 9.3.

---

From: Glauco Torres <[email-masked]>
Date: Fri, 16 Oct 2015 08:58:02 -0300

2015-10-15 18:35 GMT-03:00 Martín Marqués <[email-masked]>:

> From the README I can see that Keith suggests using 1.8.7 tag for older
> versions of pg_partman.
>
> Any thoughts on this?
>
>

Hello,

I tested now on CentOS 6.7 and installed correctly, the version that was
available for yum is 1.8.2

yum install
http://yum.postgresql.org/9.3/redhat/rhel-6-x86_64/pgdg-centos93-9.3-1.noarch.rpm

yum install pg_partman93.x86_64

yum info pg_partman93
Pacotes instalados
Name        : pg_partman93
Arch        : x86_64
Version     : 1.8.2
Release     : 1.rhel6
Size        : 1.4 M
Repo        : installed

---

From: Martín Marqués <[email-masked]>
Date: Fri, 16 Oct 2015 09:34:35 -0300

Damn, I feel really stupid. :(

I was working on a server with 9.3 but reading extension SQL files and
the python scripts from my laptop with the 9.4 package. :(

Going through the yum logs on the server I see that 1.8.2 was
installed, while on my laptop I have 2.0.0. :(

I think what really got me thinking it was 2.0 was when I checked the
spec file in the pgrpms git repository:

[martin@coruscant F-21]$ pwd
/home/martin/git/pgrpms/rpm/redhat/9.3/pg_partman/F-21
[martin@coruscant F-21]$ grep -i version pg_partman.spec
%global pgmajorversion 93
Name:           %{sname}%{pgmajorversion}
Version:        2.1.0
Source0:
http://api.pgxn.org/dist/%{sname}/%{version}/%{sname}-%{version}.zip
BuildRequires:  postgresql%{pgmajorversion}-devel
Requires:       postgresql%{pgmajorversion}-server, python-psycopg2
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%setup -q -n %{sname}-%{version}

So, that would build pg_partman93 2.1.0 for F21.

Anyway, sorry about the confusion related to the current package
version available with yum.

Regards,

2015-10-16 8:58 GMT-03:00 Glauco Torres <[email-masked]>:
> From repo   : pgdg93
> Summary     : A PostgreSQL extension to manage partitioned tables by time or
> ID
> URL         : http://pgxn.org/dist/pg_partman/
> License     : BSD
> Descrição : pg_partman is a PostgreSQL extension to manage partitioned
> tables by time or ID.
>
> ./usr/pgsql-9.3/share/extension/pg_partman--1.8.2.sql
>
> which repo you are using?
>
> Regards,
> Glauco Torres
>
>
>
>
>
>

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Glauco Torres <[email-masked]>
Date: Fri, 16 Oct 2015 09:42:30 -0300

> version available with yum.
It happens.

Regards,
Glauco Torres

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Wed, 21 Oct 2015 13:08:39 +0300

Hi,

> Name:           %{sname}%{pgmajorversion}

*sigh*, my mistake. Will fix in a few days.

Regards,
-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR