Subject: skytools build for 9.5 (EL-6 and EL-7)

From: Cédric Villemain <[email-masked]>
Date: Thu, 19 May 2016 11:21:52 +0200

fix "make rpm" for skytools, previous  path for the README files was not
correct.

It's a very simple patch, can you apply it and build packages please ?

I wonder if all specs files have to be edited one by one, is it welcome
to write a script which will prepare specs files for each EL and F
component instead ?

thank you,
-- 
Cédric Villemain +33 (0)6 20 30 22 52
http://2ndQuadrant.fr/
PostgreSQL: Support 24x7 - Développement, Expertise et Formation

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 23 May 2016 09:41:30 +0300

Hi Cédric,

> It's a very simple patch, can you apply it and build packages please ?

Thanks for the patch, but Skytools has more problems than this, AFAICS. The
latest release (3.2.6) needs some autoconf/autoreconf/autowhatever magic before
it can be compiled, and I could not fix it on Friday. I'll look at it later on.

> to write a script which will prepare specs files for each EL and F

We have unified spec files for 90% of the stuff that we build. This was the
first step. Craig is working on a solution that will exactly work as you
described. That will be the next step.

Regards,

-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Cédric Villemain <[email-masked]>
Date: Mon, 23 May 2016 18:51:30 +0200

Hi Devrim,

> it can be compiled, and I could not fix it on Friday. I'll look at it later on.

rpm were built with the patches, I confess I didn't check further.
I'm not sure RPM have support for testing builds etc ? With debian we
have a buildfarm, is there some continuous integration or Q&A in
yum.postgresql.org too ?

> described. That will be the next step.

ok, great !!

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: "Cédric Villemain" <[email-masked]>
Date: Mon, 23 May 2016 22:47:16 +0200

Hi Devrim,

ok, great !!

-- 
Cédric Villemain +33 (0)6 20 30 22 52
http://2ndQuadrant.fr/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

---

From: Martín Marqués <[email-masked]>
Date: Sun, 29 May 2016 20:50:01 -0300

Hi,

> it can be compiled, and I could not fix it on Friday. I'll look at it later on.

That's strange. I downloaded the src.rpm for skytools, changed the
postgres version in the .spec file (plus the changes from Cédic's patch)
and it compiled without a problem.

Could you expand on what compile errors you were getting?

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 31 May 2016 03:15:23 +0300

Hi,

> Could you expand on what compile errors you were getting?

Here you go:

+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --
program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr
--bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --
includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --
localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --
infodir=/usr/share/info --with-pgconfig=/usr/pgsql-9.6/bin/pg_config --
prefix=/usr/skytools-96 --with-python=/usr/bin/python
/var/tmp/rpm-tmp.e7TmxM: line 44: ./configure: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.e7TmxM (%build)

So, configure is not in the tarball. I even cannot generate it without getting
an error:

$ autoreconf 
configure.ac:138: error: possibly undefined macro: AC_USUAL_PORT_CHECK
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:139: error: possibly undefined macro: AC_USUAL_PROGRAM_CHECK
configure.ac:140: error: possibly undefined macro: AC_USUAL_HEADER_CHECK
configure.ac:141: error: possibly undefined macro: AC_USUAL_TYPE_CHECK
configure.ac:142: error: possibly undefined macro: AC_USUAL_FUNCTION_CHECK
configure.ac:149: error: possibly undefined macro: AC_USUAL_LIBEVENT_OPT
configure.ac:154: error: possibly undefined macro: AC_USUAL_DEBUG
configure.ac:155: error: possibly undefined macro: AC_USUAL_CASSERT
autoreconf: /usr/bin/autoconf failed with exit status: 1

Regards,

---

From: "Cédric Villemain" <[email-masked]>
Date: Sat, 4 Jun 2016 17:37:36 +0200

Hi Devrim,

>> That's strange. I downloaded the src.rpm for skytools, changed
>> the postgres version in the .spec file (plus the changes from
>> Cédic's patch) and it compiled without a problem.
>> 
> + ./configure --build=x86_64-redhat-linux-gnu
> --host=x86_64-redhat-linux-gnu -- program-prefix=
> --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr 
> --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
> --datadir=/usr/share -- includedir=/usr/include --libdir=/usr/lib64
> --libexecdir=/usr/libexec -- localstatedir=/var
> --sharedstatedir=/var/lib --mandir=/usr/share/man -- 
> infodir=/usr/share/info
> --with-pgconfig=/usr/pgsql-9.6/bin/pg_config -- 
> /var/tmp/rpm-tmp.e7TmxM: line 44: ./configure: No such file or
> directory error: Bad exit status from /var/tmp/rpm-tmp.e7TmxM
> (%build)
> 
> So, configure is not in the tarball. I even cannot generate it
> without getting an error:
> 
> $ autoreconf configure.ac:138: error: possibly undefined macro:
> AC_USUAL_PORT_CHECK If this token and others are legitimate, please
> use m4_pattern_allow. See the Autoconf documentation. 
> configure.ac:139: error: possibly undefined macro:
> AC_USUAL_PROGRAM_CHECK configure.ac:140: error: possibly undefined
> macro: AC_USUAL_HEADER_CHECK configure.ac:141: error: possibly
> undefined macro: AC_USUAL_TYPE_CHECK configure.ac:142: error:
> possibly undefined macro: AC_USUAL_FUNCTION_CHECK configure.ac:149:
> error: possibly undefined macro: AC_USUAL_LIBEVENT_OPT 
> configure.ac:155: error: possibly undefined macro:
> AC_USUAL_CASSERT autoreconf: /usr/bin/autoconf failed with exit
> status: 1

I didn't tried to reproduce the issue locally but I've used the
resulting packages and they work well.

Did you hit this problem when building package ? What's the command
used? (so I can do the exact same thing and debug)
What source archive did you used ? (link ?)

Thank you,

---

From: Martín Marqués <[email-masked]>
Date: Sat, 4 Jun 2016 14:40:41 -0300

Hi,

My experience was specifically with a Fedora 22 with PGDG
postgresql-9.5 packages, where all I did was:

* dnf download --source skytools-94
* rpm -ivh skytools-94-3.2-4.f22.src.rpm
* Edit skytools.spec so it compiles against 9.5 instead of 9.4
* Apply patch Cédric sent
* removed the init file which isn't used in systemd distros
* rpmbuild -ba rpmbuild/SPECS/slytools.spec

I really don't know where those errors come from. Maybe it's on RH6
with old autoconf?

Regards,