Subject: Switching to c-ares for pgbouncer?

From: Devrim Gündüz <[email-masked]>
Date: Tue, 12 Jul 2016 18:09:22 +0300

Hi,

I was reading this:

https://redmine.postgresql.org/issues/1444

Any objections for switching to c-ares for pgbouncer? From packaging point of
view, I confirmed that c-ares is available for all supported distros, but I'm
not sure about the implications.

Regards,

-- 

Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Jeff Frost <[email-masked]>
Date: Tue, 12 Jul 2016 08:14:09 -0700

> On Jul 12, 2016, at 8:09 AM, Devrim Gündüz <[email-masked]> wrote:
> 
> 
> Hi,
> 
> I was reading this:
> 

If the chart is to be believed, the only issue is:

ipv6+CNAME buggy in <=1.10

Do you know which versions are standard in the supported distros these days?

-- 
Sent via pgsql-pkg-yum mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-pkg-yum

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 12 Jul 2016 18:31:10 +0300

Hi Jeff,

> Do you know which versions are standard in the supported distros these days?

RHEL 5: 1.6.0
RHEL 6, RHEL 7, Fedora 22, Fedora 23: 1.10.0
Fedora 24, rawhide: 1.11.0

Quick note: Even though CNAME+IPv6 is buggy, that feature even does not exist
in libevent (at least this is what I understand from the chart ("ipv4 only")),
so we are not introducing new bugs here.

Regards,

-- 

Devrim GÜNDÜZ

---

From: Jeff Frost <[email-masked]>
Date: Tue, 12 Jul 2016 08:32:43 -0700

> On Jul 12, 2016, at 8:31 AM, Devrim Gündüz <[email-masked]> wrote:
> 
> 
> Hi Jeff,
> 

Sounds like at least nobody could be using ipv6 with cnames on the current setup, so I agree, it seems fine.