Subject: 'pgdg-common' -- install postgres repmgr

From: CRISTINA ASENJO CUELLAR <[email-masked]>
Date: Mon, 22 Jun 2020 11:34:06 +0000

Hello,

I installed postgres 10 on RedHat 8 (using Redhat packages)

Ø  sudo yum install @postgresql:10

I configured a replica with stream (master-slave), i want to try REPMGR (automatic failover) but i have some issus :
I added the repository:
  https://yum.postgresql.org/repopackages.php
i have tried to  install pgdg-redhat-repo-latest.noarch.rpm, but display an error: 'pgdg-common'
How i can solve it?
Below the display error:

Ø  sudo yum install pgdg-redhat-repo-latest.noarch.rpm
Updating Subscription Management repositories.
Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)                                             36 kB/s | 2.4 kB     00:00
Red Hat Enterprise Linux 8 for x86_64 - Supplementary (RPMs)                                      36 kB/s | 2.1 kB     00:00
Red Hat Satellite Tools 6.6 for RHEL 8 x86_64 (RPMs)                                              30 kB/s | 2.1 kB     00:00
Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)                                          40 kB/s | 2.8 kB     00:00
Dependencies resolved.
=================================================================================================================================
Package                             Architecture              Version                     Repository                       Size
=================================================================================================================================
Installing:
pgdg-redhat-repo                    noarch                    42.0-9                      @commandline                     10 k

Transaction Summary
=================================================================================================================================
Install  1 Package

Total size: 10 k
Installed size: 10 k
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                         1/1
  Installing       : pgdg-redhat-repo-42.0-9.noarch                                                                          1/1
  Verifying        : pgdg-redhat-repo-42.0-9.noarch                                                                          1/1
Installed products updated.
Failed to download metadata for repo 'pgdg-common'
Uploading Tracer Profile

Thanks in advance.

CRISTINA ASENJO CUELLAR
TECNOLOGÍA Y EXPLOTACIÓN
INFRAESTRUCTURA DE APLICACIONES
MADRID - AV BURGOS 109 - 28050
912146557 Ext. 6557
Antes de imprimir este correo electrónico piense bien si es necesario hacerlo: el medioambiente es cosa de todos.
​
​ADVERTENCIA LEGAL:

Este correo electrónico, y en su caso, cualquier fichero anexo al mismo, contiene información de carácter confidencial, exclusivamente dirigida a su destinatario, salvo error u omisión involuntarios. Queda prohibida su divulgación, copia o distribución a terceros, sin la previa autorización por escrito de su remitente. En el caso de haber recibido este mensaje por error, se ruega comunique esta circunstancia mediante su reenvío a la dirección electrónica del remitente y proceda a su eliminación, así como la de cualquier documento adjunto al mismo.

La Compañía ha adoptado todas las medidas a su alcance para impedir la implantación de virus informáticos en este correo y su documentación adjunta hasta el momento de su emisión, sin que asuma responsabilidad alguna por los eventuales daños o pérdidas que pueda ocasionar la recepción del mismo.

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 23 Jun 2020 10:18:00 +0100

Hi,

> Failed to download metadata for repo 'pgdg-common'

I pushed a blind fix to this, will sync a few minutes. Please let me
knnow if it does not work. 

Regards,
--
Devrim

---

From: CRISTINA ASENJO CUELLAR <[email-masked]>
Date: Tue, 23 Jun 2020 10:15:02 +0000

Hello Devrim, 

I have just tried it and there is the same error:

sudo dnf install pgdg-redhat-repo-latest.noarch.rpm
Updating Subscription Management repositories.
PostgreSQL common for RHEL/CentOS 8 - x86_64                                                  0.0  B/s |   0  B     00:28
Failed to download metadata for repo 'pgdg-common'
Error: Failed to download metadata for repo 'pgdg-common'

Thanks.

CRISTINA ASENJO CUELLAR
TECNOLOGÍA Y EXPLOTACIÓN

-----Mensaje original-----
De: Devrim Gündüz <[email-masked]> 
Enviado el: martes, 23 de junio de 2020 11:18
Para: CRISTINA ASENJO CUELLAR <[email-masked]>; [email-masked]' <[email-masked]>
Asunto: Re: 'pgdg-common' -- install postgres repmgr

Hi,

> Failed to download metadata for repo 'pgdg-common'

I pushed a blind fix to this, will sync a few minutes. Please let me knnow if it does not work. 

Regards,
--
Devrim

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 25 Jun 2020 14:09:31 +0100

Hi,

> Failed to download metadata for repo 'pgdg-common'

Can you please try running

dnf -qy disable module postgresql

dnf -v install repmgr10

and paste the output?

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR