Subject: Package updates failing

From: "Ware, Christopher M. (LARC-D318)[RSES]" <[email-masked]>
Date: Wed, 17 Apr 2024 20:16:29 +0000

Hello,
I tried to login to the system to create a ticket but I was unable to.  I tried the link to reset the password, but the email never came to my address.  I thought that maybe I didn't have an account after all and tried to create an account, but was told the email address was already in use, so I don't understand why I'm not getting the password reset email.

In any case, I'm trying to patch my Oracle Linux 8 system and am receiving the following errors when performing a dnf -y update:
dnf -y update
Last metadata expiration check: 0:24:39 ago on Wed 17 Apr 2024 03:35:19 PM EDT.
Error:
Problem 1: cannot install the best update candidate for package gdal36-libs-3.6.4-5PGDG.rhel8.x86_64
  - nothing provides libarmadillo.so.12()(64bit) needed by gdal36-libs-3.6.4-6PGDG.rhel8.x86_64 from pgdg-common
Problem 2: package postgis34_16-3.4.2-3PGDG.rhel8.x86_64 from pgdg16 requires gdal38-libs >= 3.8.4, but none of the providers can be installed
  - package postgis34_16-3.4.2-3PGDG.rhel8.x86_64 from pgdg16 requires libgdal.so.34()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package postgis34_16-3.4.2-1PGDG.rhel8.x86_64
  - nothing provides libarmadillo.so.12()(64bit) needed by gdal38-libs-3.8.5-2PGDG.rhel8.x86_64 from pgdg-common
  - nothing provides libarrow.so.800()(64bit) needed by gdal38-libs-3.8.5-2PGDG.rhel8.x86_64 from pgdg-common
  - nothing provides libarmadillo.so.12()(64bit) needed by gdal38-libs-3.8.5-3PGDG.rhel8.x86_64 from pgdg-common
  - nothing provides libarrow.so.800()(64bit) needed by gdal38-libs-3.8.5-3PGDG.rhel8.x86_64 from pgdg-common
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

The system information:
uname -a
Linux HOSTNAME 5.4.17-2136.330.7.1.el8uek.x86_64 #2 SMP Thu Apr 4 18:05:14 PDT 2024 x86_64 x86_64 x86_64 GNU/Linux

Is there an issue with dependencies that are causing these issues?
I could only get dnf to complete by using the '--nobest' option, which skips these broken links and lets the rest of the system packages update.

On a side note, how do I regain access to my account if the system already has my email and it won't send a password reset email to that account?

Thanks,
Chris

Chris Ware
RSES ATOS Systems Administrator
Analytical Mechanics Associates

t.   757.864.3003
e.  [email-masked]<mailto:[email-masked]>
w.  www.ama-inc.com<https://www.ama-inc.com/>
a.   21 Enterprise Parkway, Suite 300, Hampton, VA 23666

NASA Contact Information
t.   757.864.3003
e.  [email-masked]<mailto:[email-masked]>
a.   NASA Langley Research Center, Mail Stop 152, Bldg 1268, Rm 2092, Hampton, VA 23681

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 22 Apr 2024 17:23:15 +0100

Hi,

On Wed, 2024-04-17 at 20:16 +0000, Ware, Christopher M. (LARC-
D318)[RSES] wrote:
>   - nothing provides libarmadillo.so.12()(64bit) needed by gdal36-
> libs-3.6.4-6PGDG.rhel8.x86_64 from pgdg-common

It comes from EPEL repo. Is it enabled?

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: "Ware, Christopher M. (LARC-D318)[RSES]" <[email-masked]>
Date: Mon, 22 Apr 2024 16:40:38 +0000

Yes, I have the oracle-epel-ol8.repo enabled.
Inside the repo file are [ol8_developer_EPEL] and [ol8_developer_EPEL_modular] and both are enabled.

Am I looking at the wrong EPEL repo?

Thank you,
Chris

-----Original Message-----
From: Devrim Gündüz <[email-masked]> 
Sent: Monday, April 22, 2024 12:23 PM
To: Ware, Christopher M. (LARC-D318)[RSES] <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: Package updates failing

CAUTION: This email originated from outside of NASA.  Please take care when clicking links or opening attachments.  Use the "Report Message" button to report suspicious messages to the NASA SOC.

Hi,

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 22 Apr 2024 19:17:56 +0100

Hi,

On Mon, 2024-04-22 at 16:40 +0000, Ware, Christopher M. (LARC-
D318)[RSES] wrote:
> Inside the repo file are [ol8_developer_EPEL] and
> [ol8_developer_EPEL_modular] and both are enabled.
> 

I'm not sure about the contents of OL EPEL repo (and this is the first
time I heard it)

This is the link to the information about the repo:
https://docs.fedoraproject.org/en-US/epel/

Here is the direct download link for EL 8:

https://dl.fedoraproject.org/pub/epel/8/Everything/

Regards,

---

From: "Ware, Christopher M. (LARC-D318)[RSES]" <[email-masked]>
Date: Mon, 22 Apr 2024 19:27:18 +0000

Thank you.
Adding the Fedora EPEL repository resolved the issue.

Have a great day.
Chris

-----Original Message-----
From: Devrim Gündüz <[email-masked]>
Sent: Monday, April 22, 2024 2:18 PM
To: Ware, Christopher M. (LARC-D318)[RSES] <[email-masked]>
Cc: pgsql-pkg-yum <[email-masked]>
Subject: Re: [EXTERNAL] Re: Package updates failing

Hi,

> Am I looking at the wrong EPEL repo?

I'm not sure about the contents of OL EPEL repo (and this is the first time I heard it)

Regards,