Subject: SUSE repositories not longer available

From: Or Cohen <[email-masked]>
Date: Thu, 29 Feb 2024 10:16:59 +0000

I have noticed since the changes on the 27th this month (https://people.planetpostgresql.org/devrim/index.php?/archives/122-Installing-PostgreSQL-on-SLES-15-just-got-easier-and-better!.html) that some repositories are no longer available.
I specifically noticed it with all SuSE 15.4 repositories, and PostgreSQL 16 for SuSE 12.5 repository (also had new dependency problem on PostgreSQL 14+15 for SuSE 12.5, might be unrelated).
To be clear, SuSE 12.5 and 15.4 are currently at LTSS phase.
I haven't found any message regarding PostgreSQL dropping support for SuSE 12.5 and 15.4, so I wanted to make sure whether it was dropped intentionally or not.
If it's not planned to add these repositories back, I will appreciate if there is an archive with these packages available somewhere.

Thanks,
Or
-------------------------------------------
This message is confidential. If you believe you received this message in error, please inform the sender and delete this message and all attachments.

---

From: Matthias Apitz <[email-masked]>
Date: Thu, 29 Feb 2024 11:46:25 +0100

El día jueves, febrero 29, 2024 a las 10:16:59 +0000, Or Cohen escribió:

> ...

Interesting signature :-)
You have sent a confidential message to a mailing list with many
subscribers and which will be visible in the archive for the world until
the end of it (which could be soon).

	matthias
-- 
Matthias Apitz, ✉ [email-masked], http://www.unixarea.de/ +49-176-38902045
Public GnuPG key: http://www.unixarea.de/key.pub

I am not at war with Russia.  Я не воюю с Россией.
Ich bin nicht im Krieg mit Russland.

---

From: Or Cohen <[email-masked]>
Date: Thu, 29 Feb 2024 11:47:57 +0000

Woops.
Don't worry about it, just used wrong label.
The rest of the world is free to view the message while it can.

-----Original Message-----
From: Matthias Apitz <[email-masked]> 
Sent: Thursday, February 29, 2024 12:46 PM
To: Or Cohen <[email-masked]>
Cc: [email-masked]
Subject: Re: SUSE repositories not longer available

	matthias
-- 
Matthias Apitz, ✉ [email-masked], BLOCKEDunixarea[.]de/BLOCKED +49-176-38902045
Public GnuPG key: BLOCKEDunixarea[.]de/key[.]pubBLOCKED

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 29 Feb 2024 07:57:27 -0800

On 2/29/24 02:16, Or Cohen wrote:
> I have noticed since the changes on the 27^th this month 
> (https://people.planetpostgresql.org/devrim/index.php?/archives/122-Installing-PostgreSQL-on-SLES-15-just-got-easier-and-better!.html <https://people.planetpostgresql.org/devrim/index.php?/archives/122-Installing-PostgreSQL-on-SLES-15-just-got-easier-and-better!.html>) that some repositories are no longer available.
> 
> I specifically noticed it with all SuSE 15.4 repositories, and 
> PostgreSQL 16 for SuSE 12.5 repository (also had new dependency problem 
> on PostgreSQL 14+15 for SuSE 12.5, might be unrelated).
> 
> I haven’t found any message regarding PostgreSQL dropping support for 
> SuSE 12.5 and 15.4, so I wanted to make sure whether it was dropped 
> intentionally or not.
> 
> If it’s not planned to add these repositories back, I will appreciate if 
> there is an archive with these packages available somewhere.

Have you read?:

https://zypp.postgresql.org/news/pgdg-zypp-repo-gpg-key-update/

> This message is confidential. If you believe you received this message 
> in error, please inform the sender and delete this message and all 
> attachments.

-- 
Adrian Klaver
[email-masked]

---

From: Or Cohen <[email-masked]>
Date: Thu, 29 Feb 2024 16:07:00 +0000

I am aware of it, that's not the problem. The problem I have is repositories are non-existent, returning 404 -
https://download.postgresql.org/pub/repos/zypp/15/suse/sles-15.4-x86_64/
That's one for instance, it was the same for me for 12-16, and I can't even find a reference of PostgreSQL repo for SUSE 12.5.
I would like to know if it was intentionally removed and no longer supported, I could not find an announcement about dropping support.

-----Original Message-----
From: Adrian Klaver <[email-masked]>
Sent: Thursday, February 29, 2024 5:57 PM
To: Or Cohen <[email-masked]>; [email-masked]
Subject: Re: SUSE repositories not longer available

On 2/29/24 02:16, Or Cohen wrote:
> PostgreSQL 16 for SuSE 12.5 repository (also had new dependency
> problem on PostgreSQL 14+15 for SuSE 12.5, might be unrelated).
>
> If it’s not planned to add these repositories back, I will appreciate
> if there is an archive with these packages available somewhere.

Have you read?:

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 29 Feb 2024 08:26:43 -0800

> I would like to know if it was intentionally removed and no longer supported, I could not find an announcement about dropping support.

I see this:

https://download.postgresql.org/pub/repos/zypp/15/suse/

where SLES 15.5 and SLES 12.5 are present.

I would suggest asking over on:

https://www.postgresql.org/list/pgsql-pkg-yum/

they maybe able to sort it out better for you.

---

From: Or Cohen <[email-masked]>
Date: Thu, 29 Feb 2024 16:40:18 +0000

I have been told that it might be a better place to ask that question, I will also add that when installing on SUSE 15 SP 4 it attempts to access the repository: https://download.postgresql.org/pub/repos/zypp/15/suse/sles-15.4-x86_6, and it happens similarly on all versions of PostgreSQL repositories.
PostgreSQL 16 repository for SUSE 12 SP 5 is not mentioned at all at the updated howto: https://zypp.postgresql.org/howtozypp/.

From: Or Cohen
Sent: Thursday, February 29, 2024 12:17 PM
To: [email-masked]
Subject: SUSE repositories not longer available

Thanks,
Or

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 01 Mar 2024 10:57:36 +0000

Hi,

On Thu, 2024-02-29 at 16:40 +0000, Or Cohen wrote:
> I will also add that when installing on SUSE 15 SP 4 it attempts to
> access the repository:
> https://download.postgresql.org/pub/repos/zypp/15/suse/sles-15.4-x86_6
> , and it happens similarly on all versions of PostgreSQL repositories.

Yes, I removed all of the 15.4 (and older) from the repos this week
intentionally. Per these news:

and

https://people.planetpostgresql.org/devrim/index.php?/archives/122-Installing-PostgreSQL-on-SLES-15-just-got-easier-and-better!.html

I had to clean up everything old and start a new one, as the previous
repo layout was extremely messy, taking a lot of disk space than we
actually needed and it would take a lot of resources to install SP4 from
scratch, and rebuild packages on that one (and the dependencies would be
more messy)

OTOH, SLES 15 SP5 will be a new starting point, and I'll keep that
directory longer as compared to the previous versions.

I also removed SLES 12 SP4 and older for a different reason. Only SLES
12 SP 5 is there now for SLES 12. 

> PostgreSQL 16 repository for SUSE 12 SP 5 is not mentioned at all at
> the updated howto: https://zypp.postgresql.org/howtozypp/.

See this:

https://zypp.postgresql.org/news/sles12-postgresql-rpms-end-of-life/

I already EOLed PostgreSQL 16 on SLES 12 (and RHEL 7 for the same
reason)

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR