Subject: yum dependency issues for gdal-libs and libgeotiff with postgis25_10

From: Greg Barker <[email-masked]>
Date: Wed, 1 Jul 2020 18:21:37 -0700

I've got the pgdg10 & pgdg-common repos installed on my Amazon Linux 2
machine (RHEL7):

$ cat /etc/yum.repos.d/pgdg10.repo
[pgdg10]
name=PostgreSQL.org 10
baseurl=
https://download.postgresql.org/pub/repos/yum/10/redhat/rhel-7-$basearch
enabled=1
fastestmirror_enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-10

$ cat /etc/yum.repos.d/pgdg-common.repo
[pgdg-common]
name=PostgreSQL common for RHEL/CentOS 10
baseurl=
https://download.postgresql.org/pub/repos/yum/common/redhat/rhel-7-$basearch
enabled=1
fastestmirror_enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-10

postgis25_10 is installed:

$ yum list installed | grep postgis25_10
postgis25_10.x86_64                2.5.4-2.rhel7                    @pgdg10

However, when I try to do a yum update now, it fails:

$ sudo yum update -y
Loaded plugins: langpacks, priorities, update-motd
amzn2-core

                                                                | 3.7 kB
 00:00:00
280 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package libgeotiff.x86_64 0:1.2.5-14.el7 will be updated
--> Processing Dependency: libgeotiff.so.1.2()(64bit) for package:
gdal-libs-1.11.4-3.el7.x86_64
--> Processing Dependency: libgeotiff.so.1.2()(64bit) for package:
gdal-1.11.4-3.el7.x86_64
---> Package libgeotiff.x86_64 0:1.4.0-1.rhel7 will be an update
--> Finished Dependency Resolution
Error: Package: gdal-libs-1.11.4-3.el7.x86_64 (@epel)
           Requires: libgeotiff.so.1.2()(64bit)
           Removing: libgeotiff-1.2.5-14.el7.x86_64 (@epel)
               libgeotiff.so.1.2()(64bit)
           Updated By: libgeotiff-1.4.0-1.rhel7.x86_64 (pgdg-common)
               Not found
Error: Package: gdal-1.11.4-3.el7.x86_64 (@epel)
           Requires: libgeotiff.so.1.2()(64bit)
           Removing: libgeotiff-1.2.5-14.el7.x86_64 (@epel)
               libgeotiff.so.1.2()(64bit)
           Updated By: libgeotiff-1.4.0-1.rhel7.x86_64 (pgdg-common)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I came across a few posts where folks had run into this in the past, seemed
like some sort of packaging issue that had to be fixed:
https://postgrespro.com/list/thread-id/2199483

Thanks!
Greg

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 02 Jul 2020 12:28:09 +0100

Hi,

On Wed, 2020-07-01 at 18:21 -0700, Greg Barker wrote:
> I came across a few posts where folks had run into this in the past,
> seemed like some sort of packaging issue that had to be fixed: 

Down in the thread, the issue seems to be resolved. I think the gdal-*
packages must be removed prior to upgrade:

yum remove gdal-*

yum update

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR