Subject: gdal30 and Rhel 8.4 dependency problem

From: Svensson Peter <[email-masked]>
Date: Thu, 27 May 2021 07:31:34 +0000

Hi,

We use gdal30 in Rhel 8, but when are going to upgrade to Rhel 8.4  we got dependency problem with poppler

If we then remove gdal30,  upgrade to Rhel 8.4 and then try to install gdal30,  dnf will downgrade poppler  and cups

I tried with the package gdal30-3.0.4-4.rhel8.x86_64.rpm   from this repository:
https://download.postgresql.org/pub/repos/yum/common/redhat/rhel-8.4-x86_64/

Can you please  rebuild   gdal30 to support the version of poppler used in Rhel 8.4

best regards,
Peter

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 27 May 2021 14:34:09 +0100

Hi,

> Can you please  rebuild   gdal30 to support the version of poppler

Can you please install gdal32? Thanks.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Svensson Peter <[email-masked]>
Date: Thu, 27 May 2021 13:54:17 +0000

Hi,

No sorry, but we have some in house built system with hard requirements to gdal30.

As we saw that you had gdal30 in rhel8.4 repo we thought you could rebuild that.

Regards

Peter

________________________________
Från: Devrim Gündüz <[email-masked]>
Skickat: den 27 maj 2021 15:34
Till: Svensson Peter; [email-masked]
Ämne: Re: gdal30 and Rhel 8.4 dependency problem

Hi,

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 27 May 2021 15:31:14 +0100

Hi,

> As we saw that you had gdal30 in rhel8.4 repo we thought you could

Well, I'm sure you (and Daryl) found a hole in the GIS stack. All of
the RPMs *should* require gdal32. Can you please let me know which
versions of PostGIS, PROJ and GeOS you are using?

Regards,

---

From: Svensson Peter <[email-masked]>
Date: Fri, 28 May 2021 06:23:49 +0000

Hi,

We use in this combination  proj70 , geos38 and postgis24

But gdal30 requires libproj.so.19()(64bit)  so I think even proj72 will work.

and gdal30-libs requires libgeos_c.so.1()(64bit)  so even geos39 are possible

postgis24 requires libgdal.so.26()(64bit)

Regards,
Peter

________________________________
Från: Devrim Gündüz <[email-masked]>
Skickat: den 27 maj 2021 16:31
Till: Svensson Peter; [email-masked]
Ämne: Re: SV: gdal30 and Rhel 8.4 dependency problem

Hi,

Regards,

---

From: Devrim Gündüz <[email-masked]>
Date: Fri, 28 May 2021 08:13:34 +0100

Hi,

> We use in this combination  proj70 , geos38 and postgis24

Ahh, that now makes sense (see below) . 

> But gdal30 requires libproj.so.19()(64bit)  so I think even proj72 will

My very original plan was to support a single GeOS/GDAL/PROJ
combination across all PostGIS installations, which miserably failed
after PROJ 8.0:

checking for proj_api.h... no
configure: error: could not find proj_api.h - you may need to specify
the directory of a PROJ.4 installation using --with-projdir

Upstream patched 3.0 and 3.1 for that, and that is why users of the
recent versions actually have no issues.

> postgis24 requires libgdal.so.26()(64bit)

I even removed gdal30 spec files from pgdg repos a few months ago :-) 

Let me see what I can do. Either I will solve the problem on the
packaging side, or will just as users to add these packages to
exclude=... list, so that yum/dnf update won't complain.

Regards,