Subject: missing scripts in CentOS6 PG10 server package

From: Martin Marques <[email-masked]>
Date: Mon, 25 Jun 2018 22:29:09 -0300

Hi,

Today I had to set up a 10 server and when trying to use
postgresql-10-setup I found it was missing (together with
postgresql-10-check-db-dir as well)

The scripts are available in Fedora, but not CentOS 6 (couldn't check
CentOS 7 yet)

I can't find any reason why the would not be present on CentOS6.

Are they just missing or is there a reason for them not being there?

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services

---

From: Devrim Gündüz <[email-masked]>
Date: Wed, 27 Jun 2018 00:35:28 +0100

Hi Martin,

> Are they just missing or is there a reason for them not being there?

That script is for systemd-based distros -- you need to use the old way to
initdb on CentOS 6:

service postgresql-11 initdb

Regards,

-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR