Subject: Postges 11 Proj Dep Error CentOS 7

From: Scott Mugnaini <[email-masked]>
Date: Wed, 24 Oct 2018 18:17:24 +0300

Hi -
Using repo on CentOS 7, along with epel7, PostGIS 2.5 installs without
error, but adding extension throws error below.
'/usr/pgsql-11/lib/postgis-2.5.so: undefined symbol: geod_polygon_init'
This seems to be the result of the pg repo using proj from epel (which is
version 4.8) to meet dep, while the pg repo version is the required 4.9
> Installed Packages
proj.x86_64                               4.8.0-4.el7
@epel
proj49.x86_64                             4.9.3-3.rhel7.1
@pgdg11
Have tried remove/install but pg repo just pulls in proj from epel again.

Thanks,
Scott

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 30 Oct 2018 11:19:34 +0000

Hi,

> Have tried remove/install but pg repo just pulls in proj from epel again.

I'm working on it, will try to fix before EOD.

Regards,

-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR