Subject: Postgres client/utilities for CentOS 7

From: "Heckler, Kim M" <[email-masked]>
Date: Fri, 8 Dec 2023 17:19:48 +0000

To whom it may concern,

Unfortunately, I cannot install Postgres using a yum install command pointing to an external webpage.  I must first download to my laptop, upload to my Linux server and then manually install.  I've done this numerous times in the past but I am not running into a problem.  I am trying to download v16.1 of the client tools/utilities.  i.e. psql, pg_dump   The file I normally download are:

postgresql15-libs-15.4-1PGDG.rhel7.x86_64.rpm
postgresql15-15.4-1PGDG.rhel7.x86_64.rpm

When searching your download sites/pages, I do not see packages, for v16, for CentOS 7.  Can you provide assistance?

Thank you, Kim.

[Nationwide is on your side.]
Kim M. Heckler
Consultant, Technology Delivery Professional
Proud Nationwide Member
Database Technology
614-249-3014
740-816-0908
[email-masked]<mailto:[email-masked]>

---

From: Laurenz Albe <[email-masked]>
Date: Fri, 08 Dec 2023 18:31:49 +0100

On Fri, 2023-12-08 at 17:19 +0000, Heckler, Kim M wrote:
> I am trying to download v16.1 of the client tools/utilities.
>  

We don't provide packages for new PostgreSQL versions on RHEL 7.
Upgrade to a more recent RHEL release.

Yours,
Laurenz Albe