Subject: Error: Failed to download metadata for repo 'pgdg13': repomd.xml GPG signature verification error: Bad GPG signature

From: •Isaac Rv <[email-masked]>
Date: Fri, 3 May 2024 11:54:18 -0600

Hello, I'm getting this error even though I've tried to update the GPG.

In the repository cd /etc/pki/rpm-gpg/, I have the following:

ISV-Container-signing-key
PGDG-RPM-GPG-KEY-RHEL
RPM-GPG-KEY-EPEL-8
RPM-GPG-KEY-PGDG
RPM-GPG-KEY-PGDG-AARCH64-RHEL8
RPM-GPG-KEY-redhat-beta
RPM-GPG-KEY-redhat-release

In the pgdg-redhat-all.repo repository, I made this change in all sections
of postgres 13:

[pgdg13]
name=PostgreSQL 13 for RHEL / Rocky $releasever - $basearch
baseurl=
https://download.postgresql.org/pub/repos/yum/13/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-AARCH64-RHEL8
repo_gpgcheck = 1

My operating system is Red Hat Enterprise Linux 8.8

And when running the yum install command to upgrade from 13.12 to 13.14, I
get the Bad GPG signature error.

Please help me, thank you very much.

---

From: Devrim Gündüz <[email-masked]>
Date: Mon, 06 May 2024 12:35:14 +0100

Hi,

> Hello, I'm getting this error even though I've tried to update the

<snip>

This is my reply to you on redmine:

https://redmine.postgresql.org/issues/7989

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, PostgreSQL Major Contributor
Twitter: @DevrimGunduz , @DevrimGunduzTR