Subject: PG11rc1 / centos7; and, RH6 schedule

From: Justin Pryzby <[email-masked]>
Date: Tue, 16 Oct 2018 13:36:16 -0500

Hi,

Wanted to point out that PG11rc1 isn't installable centos7 due to dependencies:

Error: Package: postgis24_11-2.4.5-1.rhel7.x86_64 (pgdg11)
           Requires: SFCGAL
Error: Package: postgis24_11-2.4.5-1.rhel7.x86_64 (pgdg11)
           Requires: libSFCGAL.so.1()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg11)
           Requires: libgeotiff.so.2()(64bit)

I worked around it by installing repo for PG10:

Installing:
 postgis24_11                              x86_64                              2.4.5-1.rhel7                                   pgdg11                              5.2 M
Installing for dependencies:
 CGAL                                      x86_64                              4.7-1.rhel7                                     pgdg10                              254 k
 SFCGAL                                    x86_64                              1.2.2-1.rhel7                                   pgdg10                               14 k
 SFCGAL-libs                               x86_64                              1.2.2-1.rhel7                                   pgdg10                              1.7 M
 gdal-libs                                 x86_64                              1.11.4-12.rhel7                                 pgdg10                              4.4 M
 geos36                                    x86_64                              3.6.3-1.rhel7                                   pgdg10                              543 k
 libgeotiff                                x86_64                              1.4.0-1.rhel7                                   pgdg10                              708 k
 ogdi                                      x86_64                              3.2.0-4.rhel7                                   pgdg10                              248 k
 proj49                                    x86_64                              4.9.3-3.rhel7                                   pgdg10                              215 k

Also, I'm still wondering how long we can expect updates for RH6 to continue?
It'd be good to have a plan for patchlevel updates or major releases.

Thanks,
Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Thu, 18 Oct 2018 11:49:40 +0100

Hi,

>            Requires: libgeotiff.so.2()(64bit)

:-( Thanks for the report. Fixed. I will release them along with 11.0 packages.

> It'd be good to have a plan for patchlevel updates or major releases.

RHEL 6 support will continue at least until 2020, or probably even until 2024,
depending on if upstream projects can still be compiled on RHEL 6 until then.

Regards,
-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: Justin Pryzby <[email-masked]>
Date: Thu, 18 Oct 2018 10:41:28 -0500

> depending on if upstream projects can still be compiled on RHEL 6 until then.

Thanks.  Note that the links to centos6 PGDG RPMs are broken as of today:

https://yum.postgresql.org/repopackages.php#pg11
=> https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-6-x86_64/pgdg-centos11-11-2.noarch.rpm
=> 404

-- 
Justin Pryzby
System Administrator
Telsasoft
+1-952-707-8581