Subject: Need some assistance please

From: "Josserand, Jesse F (NE)" <[email-masked]>
Date: Thu, 10 Sep 2020 21:28:19 +0000

Hello support team.
I'm doing some work for GDIT on gov't project and in my analysis of environments have found some issues most of which I can resolve myself, but there are 3 things I could use your direction on, if you please...

1.       May I get specific instructions on how to do the appropriate yum repo update for postgresql as described at a high level on this page: https://yum.postgresql.org/news/new-repo-rpms-released/. I'm running on both CentOS 7.8 and RHEL 7.8 in my 2 main environments.

2.       I want to convert to 'dnf' from 'yum' and could use a 1, 2, 3-style write-up of that procedure.

3.       Finally, and this is most important of all... my instances of PostgreSQL were at 10.10 when I got here. I have taken them from there through 10.11, 10.12, 10.13, and now 10.14 successfully. However, I just discovered that the DBA/Sysadmin before me did not correctly migrate nor update PostGIS when going from some version of 9.x.x to 10.10 before I took over. I have discovered the existence of PostGIS 2.5 in 2 databases out of all the databases in my instance of PostgreSQL 10.14. What do I need to do, if anything, to ensure they are up-to-date and useable? Please provide a detailed step-by-step.
Thanks in advance!
:)
Jess
[TekSynap - Technology Moving at the Speed of Thought]<https://www.teksynap.com/>
Jesse F. Josserand  |  Sr. Systems Architect/SysAdmin/DB Analyst
M: 601-590-0304  |  D: 228-469-2019  |  [email-masked]<mailto:[email-masked]>
www.TekSynap.com<https://www.teksynap.com/>  |  1760 Reston Parkway, Suite 515, Reston VA 20190
Assigned to GDIT Project, 294 Thames Avenue, Bay St. Louis, MS 39520
[email-masked]<mailto:[email-masked]>
[Connect with TekSynap on LinkedIn]<https://www.linkedin.com/company/teksynap/>
 |
[Save vCard]<https://www.teksynap.com/teksynap_signatures/Jesse_Josserand/?vcard=1>

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 15 Sep 2020 14:19:50 +0100

Hi,

On Thu, 2020-09-10 at 21:28 +0000, Josserand, Jesse F (NE) wrote:

> 
> 1.       May I get specific instructions on how to do the appropriate
> yum repo update for postgresql as described at a high level on this
> page: https://yum.postgresql.org/news/new-repo-rpms-released/. I'm
> running on both CentOS 7.8 and RHEL 7.8 in my 2 main environments.

yum update pgdg-redhat* will do the trick for you.

> 3-style write-up of that procedure.

Why do you want to move to dnf? It works on RHEL 7, but it's more for
RHEL 8.

> 
> 3.       Finally, and this is most important of all... my instances
> of PostgreSQL were at 10.10 when I got here. I have taken them from
> there through 10.11, 10.12, 10.13, and now 10.14 successfully.
> However, I just discovered that the DBA/Sysadmin before me did not
> correctly migrate nor update PostGIS when going from some version of
> 9.x.x to 10.10 before I took over. I have discovered the existence of
> PostGIS 2.5 in 2 databases out of all the databases in my instance of
> PostgreSQL 10.14. What do I need to do, if anything, to ensure they
> are up-to-date and useable? Please provide a detailed step-by-step.
> Thanks in advance!

Please send this question to PostGIS list.

Regards,
-- 
Devrim Gündüz
Open Source Solution Architect, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

---

From: "Josserand, Jesse F (NE)" <[email-masked]>
Date: Tue, 15 Sep 2020 14:25:27 +0000

Thank you kindly!
FYI, I appreciate the info on dnf. I just seems from what I have read that yum is being deprecated/replaced by dnf. Perhaps that was a misinterpretation on my part.
Also, for what it's worth, I'd updated the repo's as you suggested, but the subsequent simple yum install or yum update statements for PostgreSQL and PostGIS do nothing. Not sure why, but it seems I must specify specific packages and/or rpm names to get yum to do anything.
Thanks again.
:)
Jess

Jesse F. Josserand  |  Sr. Systems Architect/SysAdmin/DB Analyst
M: 601-590-0304  |  D: 228-469-2019  |  [email-masked]
www.TekSynap.com  |  1760 Reston Parkway, Suite 515, Reston VA 20190
Assigned to GDIT Project, 294 Thames Avenue, Bay St. Louis, MS 39520
[email-masked]

 | 

-----Original Message-----
From: Devrim Gündüz <[email-masked]> 
Sent: Tuesday, September 15, 2020 8:20 AM
To: Josserand, Jesse F (NE) <[email-masked]>; [email-masked]
Subject: Re: Need some assistance please

 [External: Use caution with links & attachments]

Hi,

> 3-style write-up of that procedure.

Why do you want to move to dnf? It works on RHEL 7, but it's more for RHEL 8.

Regards,