Subject: PostgreSQL 16 and PostGIS

From: Simon Connah <[email-masked]>
Date: Mon, 13 Nov 2023 07:00:43 +0000

Hi,

I originally posted in the PostgreSQL novice list that I had installed PostgreSQL 16 on Rocky Linux 9 using this method:

https://www.postgresql.org/download/linux/redhat/

and it works perfectly. But when I try and install PostGIS I ended up getting this error:

[root@139-162-197-226 simon]# dnf update
Last metadata expiration check: 1:11:27 ago on Mon 13 Nov 2023 05:02:27 AM UTC.
Dependencies resolved.
Nothing to do.
Complete!
[root@139-162-197-226 simon]# dnf install postgis34_16
Last metadata expiration check: 1:11:40 ago on Mon 13 Nov 2023 05:02:27 AM UTC.
Error:
 Problem: package postgis34_16-3.4.0-1PGDG.rhel9.x86_64 requires gdal36-libs >= 3.6.3, but none of the providers can be installed
  - package postgis34_16-3.4.0-1PGDG.rhel9.x86_64 requires libgdal.so.32()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libqhull_r.so.7()(64bit) needed by gdal36-libs-3.6.4-4PGDG.rhel9.x86_64
  - nothing provides libqhull_r.so.7()(64bit) needed by gdal36-libs-3.6.4-5PGDG.rhel9.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Is there any fix to this at all?

Thank you.

Simon.

---

From: "Regina Obe" <[email-masked]>
Date: Mon, 13 Nov 2023 02:10:19 -0500

> [root@139-162-197-226 simon]# dnf update Last metadata expiration check:
> 1:11:27 ago on Mon 13 Nov 2023 05:02:27 AM UTC.
> Dependencies resolved.
> Nothing to do.
> Complete!
> [root@139-162-197-226 simon]# dnf install postgis34_16 Last metadata
> expiration check: 1:11:40 ago on Mon 13 Nov 2023 05:02:27 AM UTC.
> Error:
>  Problem: package postgis34_16-3.4.0-1PGDG.rhel9.x86_64 requires gdal36-
> libs >= 3.6.3, but none of the providers can be installed
>   - package postgis34_16-3.4.0-1PGDG.rhel9.x86_64 requires
> libgdal.so.32()(64bit), but none of the providers can be installed
>   - conflicting requests

I think you might be missing the 

crb enable

step that Devrim mentioned in an email thread.

FWIW, I've updated the Yum instructions on postgis.net t o include that.

https://postgis.net/documentation/getting_started/install_red_hat/

Let me know if all that works for you or if I missed anything.
Those worked for me, but I was testing with Rocky8

---

From: Simon Connah <[email-masked]>
Date: Mon, 13 Nov 2023 07:29:44 +0000

Hi,

I got it installed but had to change a command to get it to work.

I used the following:

dnf -y install epel-release
dnf config-manager --enable crb
crb enable
dnf -y install postgis34_16
systemctl restart postgresql-16

Simon.