Subject: How come column is locked?

From: Shaozhong SHI <[email-masked]>
Date: Tue, 4 Jul 2023 15:34:40 +0100

Hi,

I used

create table if not exists waternetwork1.walknetwortt3 (fid integer[]);

in do statement.

When I use
insert into waternetwork1.walknetwortt3 select fid from a function

it failed.

The column is locked.

Regards,

David

---

From: William Alves Da Silva <[email-masked]>
Date: Tue, 4 Jul 2023 11:40:23 -0300

Hello,

In PostgreSQL, DDL statements will get lock, if you don’t commit the change, all futures queries will be put on hold.

Reggards,
WIlliam Alves

> On 4 Jul 2023, at 11:34, Shaozhong SHI <[email-masked]> wrote:
> 
> Hi, 
> 
> I used
>

---

From: Thomas Kellerer <[email-masked]>
Date: Tue, 4 Jul 2023 16:43:15 +0200

> insert into waternetwork1.walknetwortt3 select fid from a function

What exactly is the error message you get?

> The column is locked.

There is no column level lock in Postgres.

The smallest unit that can be locked is a row.

---

From: Tom Lane <[email-masked]>
Date: Tue, 04 Jul 2023 10:47:47 -0400

> create table if not exists waternetwork1.walknetwortt3 (fid integer[]);

Perhaps the table already existed, with some other column list?

> insert into waternetwork1.walknetwortt3 select fid from a function

"It failed" is totally inadequate as a description of the problem.
Did you read the error message?  What does it say, exactly?

			regards, tom lane

---

From: Thomas Kellerer <[email-masked]>
Date: Tue, 4 Jul 2023 20:39:09 +0200

Shaozhong SHI schrieb am 04.07.2023 um 16:59:
> On Tue, 4 Jul 2023 at 15:43, Thomas Kellerer <[email-masked] <mailto:[email-masked]>> wrote:
>
> I see a pad lock on the column.  That is the only column.

There is no such thing as a "padlock" in Postgres.

---

From: Rob Sargent <[email-masked]>
Date: Tue, 4 Jul 2023 17:27:52 -0600

On 7/4/23 12:39, Thomas Kellerer wrote:
>>      > I used
>>      >
>>      > create table if not exists waternetwork1.walknetwortt3 (fid 
>> integer[]);
>>      >
>>      > in do statement.
>>      >
>>      > When I use
>>      > insert into waternetwork1.walknetwortt3 select fid from a 
>> function
>>      >
>>      > it failed.
>>
>>      > The column is locked.
GUI-speak for primary key, perhaps?