Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1XbvXF-0001t3-27 for pgsql-sql@arkaria.postgresql.org; Wed, 08 Oct 2014 18:00:25 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.80) (envelope-from ) id 1XbvXD-0006NZ-Hv for pgsql-sql@arkaria.postgresql.org; Wed, 08 Oct 2014 18:00:23 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:DHE_RSA_AES_256_CBC_SHA256:256) (Exim 4.80) (envelope-from ) id 1XbvXC-0006NK-GV for pgsql-sql@postgresql.org; Wed, 08 Oct 2014 18:00:22 +0000 Received: from sam.nabble.com ([216.139.236.26]) by magus.postgresql.org with esmtps (TLS1.0:RSA_AES_256_CBC_SHA1:256) (Exim 4.80) (envelope-from ) id 1XbvX7-0003zZ-Gk for pgsql-sql@postgresql.org; Wed, 08 Oct 2014 18:00:20 +0000 Received: from [192.168.236.26] (helo=sam.nabble.com) by sam.nabble.com with esmtp (Exim 4.72) (envelope-from ) id 1XbvX3-0006oX-Jn for pgsql-sql@postgresql.org; Wed, 08 Oct 2014 11:00:13 -0700 Date: Wed, 8 Oct 2014 11:00:13 -0700 (PDT) From: jim_yates To: pgsql-sql@postgresql.org Message-ID: <1412791213607-5822248.post@n5.nabble.com> Subject: could not access status of transaction pg_multixact issue MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -0.8 (/) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org I have this issue for 1 table. Version is 9.3.5 upgraded from 9.2 with pg_upgrade a few months ago. This issues just started in the last couple of days. acustream=# SELECT count(*) from phyorg_charges_to_invoice; ERROR: could not access status of transaction 267035 DETAIL: Could not open file "pg_multixact/members/10AD6": No such file or directory. This error happens when I try and select or vacuum the table. Inserts still work. I have a hot standby database and I can recover the data from there. Is there any work around for this?