Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1asgip-0002p4-GH for pgsql-sql@arkaria.postgresql.org; Wed, 20 Apr 2016 01:14:27 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84_2) (envelope-from ) id 1asgip-0005uk-2h for pgsql-sql@arkaria.postgresql.org; Wed, 20 Apr 2016 01:14:27 +0000 Received: from makus.postgresql.org ([2001:4800:1501:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1asOmk-0000R3-97 for pgsql-sql@postgresql.org; Tue, 19 Apr 2016 06:05:18 +0000 Received: from mbob.nabble.com ([162.253.133.15]) by makus.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1asOmh-0008Q1-BW for pgsql-sql@postgresql.org; Tue, 19 Apr 2016 06:05:16 +0000 Received: from msam.nabble.com (unknown [162.253.133.85]) by mbob.nabble.com (Postfix) with ESMTP id 188A725918F7 for ; Mon, 18 Apr 2016 22:51:51 -0700 (PDT) Date: Mon, 18 Apr 2016 23:05:13 -0700 (MST) From: msn To: pgsql-sql@postgresql.org Message-ID: <1461045913793-5899379.post@n5.nabble.com> Subject: org.postgresql.util.PSQLException: ERROR: index row requires more memory than default(8191) MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -0.3 (/) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org I am trying to use PostgreSQL in our existing project to improve the performance and make it fiendly with JSON. I have done some research on the PostgerSQL and trying to integrate it into our application. But I am facing some problem when I tried to insert the large json document into the table. It is working with small set of json document but fails with the large data. The following is the error dispalyed in the console when inserting the data. org.postgresql.util.PSQLException: ERROR: index row requires 11936 bytes, maximum size is 8191 at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2284) at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2003) at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:200) at org.postgresql.jdbc.PgStatement.execute(PgStatement.java:424) at org.postgresql.jdbc.PgStatement.executeWithFlags(PgStatement.java:321) at org.postgresql.jdbc.PgStatement.executeUpdate(PgStatement.java:297) at com.practice.PracticeClass.main(PracticeClass.java:28) org.postgresql.util.PSQLException: ERROR: index row requires 11936 bytes, maximum size is 8191 In the above error, It is saying memory is not sufficient to create an index. I am new to this Postgres. I am not creating any index when inserting the json document. I am thinking it is internally creating an index for the column. Table creation: Create table sample(id serial, info jsonb); Could any tell me how to resolve this error or how to configure to increase the memory to insert large data. -- View this message in context: http://postgresql.nabble.com/org-postgresql-util-PSQLException-ERROR-index-row-requires-more-memory-than-default-8191-tp5899379.html Sent from the PostgreSQL - sql mailing list archive at Nabble.com. -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql