Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1eEYHn-0000UQ-Lg for pgsql-sql@arkaria.postgresql.org; Tue, 14 Nov 2017 10:17:43 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84_2) (envelope-from ) id 1eEYHn-0005dF-7r for pgsql-sql@arkaria.postgresql.org; Tue, 14 Nov 2017 10:17:43 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1eEYHm-0005cF-7I for pgsql-sql@postgresql.org; Tue, 14 Nov 2017 10:17:42 +0000 Received: from n3.nabble.com ([162.255.23.22]) by magus.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1eEYHh-0003GM-OR for pgsql-sql@postgresql.org; Tue, 14 Nov 2017 10:17:41 +0000 Received: from n3.nabble.com (localhost [127.0.0.1]) by n3.nabble.com (Postfix) with ESMTP id 3A57796E6DFB for ; Tue, 14 Nov 2017 03:17:36 -0700 (MST) Date: Tue, 14 Nov 2017 03:17:36 -0700 (MST) From: queralt To: pgsql-sql@postgresql.org Message-ID: <1510654656203-0.post@n3.nabble.com> Subject: Line number returned in Postgres Raise Exception sentence MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7bit List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org We are migrating a system from Postgres 9.2 to Postgres 9.6. The problem is that in migrating the Stored Procedures, where we use the RAISE EXCEPTION sentence, a new line is added in the message returned when there is a RAISE EXCEPTION. In our system the existence of this second part of the message is a big problem. "ERROR: Message of Error SQL state: P0001 Context: function PL/pgSQL xxx() in line 4 of RAISE" We are executing stored procedures from JDBC and obtain the message with getMessage and from PgAdmin III or IV. We would like to know if there is the possibility to configure Postgres 9.6 in order this part of the message does not appear. Or maybe if it is possible to set some attribute during the database connection. We have read about a solution changing in the file postgres.config the attribute log_error_verbosity to terse. We did but it has no effect in the result. -- Sent from: http://www.postgresql-archive.org/PostgreSQL-sql-f2142323.html -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql