Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1ZRAum-0000kD-C7 for pgsql-sql@arkaria.postgresql.org; Mon, 17 Aug 2015 03:16:48 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84) (envelope-from ) id 1ZRAuk-0004CO-R2 for pgsql-sql@arkaria.postgresql.org; Mon, 17 Aug 2015 03:16:46 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1ZRAuh-0004AY-Ph for pgsql-sql@postgresql.org; Mon, 17 Aug 2015 03:16:43 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1ZRAue-00026f-J3 for pgsql-sql@postgresql.org; Mon, 17 Aug 2015 03:16:42 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id t7H3GZWj015242; Sun, 16 Aug 2015 23:16:35 -0400 From: Tom Lane To: Stuart cc: "pgsql-sql@postgresql.org" Subject: Re: ERROR: cache lookup failed for type In-reply-to: <55D131B0.6010500@gmail.com> References: <55D131B0.6010500@gmail.com> Comments: In-reply-to Stuart message dated "Mon, 17 Aug 2015 04:58:24 +0400" Date: Sun, 16 Aug 2015 23:16:35 -0400 Message-ID: <15241.1439781395@sss.pgh.pa.us> X-Pg-Spam-Score: -2.6 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org Stuart writes: > I have been using a particular function for years without issue but > recently tried the Alpha releases of PostGreSQL. I loaded the database > into 9.5 Alpha1 release and did not have problems. After upgrading to > Alpha2, I started getting this error on executing the function. I didn't > reload the database this time as it should not be required. > ERROR: cache lookup failed for type 1082 > CONTEXT: compilation of PL/pgSQL function "ds_stats" near line 1 That's odd. > I dropped the function and can now not add it back to the database. What happens when you try, exactly? I assume the error was persistent across multiple sessions? Have you changed the schema (rowtype) of table documents_statistics lately? Does reindexing pg_type make the error go away? If so, what platform and filesystem is this on? regards, tom lane -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql