Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1XbwOr-0004Cc-B6 for pgsql-sql@arkaria.postgresql.org; Wed, 08 Oct 2014 18:55:49 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.80) (envelope-from ) id 1XbwOq-00017I-Mh for pgsql-sql@arkaria.postgresql.org; Wed, 08 Oct 2014 18:55:48 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:DHE_RSA_AES_256_CBC_SHA256:256) (Exim 4.80) (envelope-from ) id 1XbwOp-000178-Mm for pgsql-sql@postgresql.org; Wed, 08 Oct 2014 18:55:47 +0000 Received: from smtprelay0071.b.hostedemail.com ([64.98.42.71] helo=smtprelay.b.hostedemail.com) by magus.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1XbwOl-000529-2M for pgsql-sql@postgresql.org; Wed, 08 Oct 2014 18:55:46 +0000 Received: from filter.hostedemail.com (b-bigip1 [10.5.19.254]) by smtprelay05.b.hostedemail.com (Postfix) with ESMTP id 6AC6932AC1A; Wed, 8 Oct 2014 18:55:41 +0000 (UTC) X-Session-Marker: 616C76686572726540616C76682E6E6F2D69702E6F7267 X-Spam-Summary: 50, 0, 0, , d41d8cd98f00b204, alvherre@alvh.no-ip.org, :::, RULES_HIT:41:355:379:599:967:973:988:989:1260:1277:1311:1312:1313:1314:1345:1359:1437:1515:1516:1518:1519:1534:1540:1593:1594:1595:1596:1711:1730:1747:1777:1792:2198:2199:2393:2525:2561:2564:2682:2685:2828:2859:2895:2901:2933:2937:2939:2942:2945:2947:2951:2954:3022:3138:3139:3140:3141:3142:3352:3865:3866:3867:3868:3870:3871:3873:3934:3936:3938:3941:3944:3947:3950:3953:3956:3959:4321:4605:4659:5007:6119:6261:7903:8599:9025:9121:9388:10004:10400:10848:11026:11232:11256:11257:11658:11914:12043:12050:12292:12438:12517:12519:12555:12660:12682:13069:13095:13160:13163:13229:13311:13357:13845:13894:13895:21080, 0, RBL:none, CacheIP:none, Bayesian:0.5, 0.5, 0.5, Netcheck:none, DomainCache:0, MSF:not bulk, SPF:fn, MSBL:0, DNSBL:none, Custom_rules:0:0:0 X-HE-Tag: bikes48_4eb2f72fafe3a X-Filterd-Recvd-Size: 1863 Received: from eldon.alvh.no-ip.org (unknown [186.11.245.196]) (Authenticated sender: alvherre@alvh.no-ip.org) by omf11.b.hostedemail.com (Postfix) with ESMTPA; Wed, 8 Oct 2014 18:55:40 +0000 (UTC) Received: by eldon.alvh.no-ip.org (Postfix, from userid 1000) id 0B9251FCC; Wed, 8 Oct 2014 15:55:38 -0300 (CLST) Date: Wed, 8 Oct 2014 15:55:38 -0300 From: Alvaro Herrera To: jim_yates Cc: pgsql-sql@postgresql.org Subject: Re: could not access status of transaction pg_multixact issue Message-ID: <20141008185538.GY7043@eldon.alvh.no-ip.org> References: <1412791213607-5822248.post@n5.nabble.com> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <1412791213607-5822248.post@n5.nabble.com> User-Agent: Mutt/1.5.21 (2010-09-15) X-Pg-Spam-Score: -1.9 (-) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org jim_yates wrote: > I have this issue for 1 table. Version is 9.3.5 upgraded from 9.2 with > pg_upgrade a few months ago. > > This issues just started in the last couple of days. > > acustream=# SELECT count(*) from phyorg_charges_to_invoice; > ERROR: could not access status of transaction 267035 > DETAIL: Could not open file "pg_multixact/members/10AD6": No such file or > directory. > > This error happens when I try and select or vacuum the table. Inserts still > work. I have a hot standby database and I can recover the data from there. > Is there any work around for this? Please see this thread: http://www.postgresql.org/message-id/loom.20140930T022539-927@post.gmane.org My bet is you upgraded to a 9.3 version older than 9.3.5; this means your relminmxid/datminmxid are set to 1 and need to be updated. -- Álvaro Herrera http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Training & Services -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql