Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1ZRBTz-0002Aj-Uc for pgsql-sql@arkaria.postgresql.org; Mon, 17 Aug 2015 03:53:12 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84) (envelope-from ) id 1ZRBTy-00077d-Tt for pgsql-sql@arkaria.postgresql.org; Mon, 17 Aug 2015 03:53:10 +0000 Received: from makus.postgresql.org ([2001:4800:1501:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1ZRBT1-00062b-Ce for pgsql-sql@postgresql.org; Mon, 17 Aug 2015 03:52:11 +0000 Received: from mail-pa0-x234.google.com ([2607:f8b0:400e:c03::234]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.84) (envelope-from ) id 1ZRBSy-0002up-2t for pgsql-sql@postgresql.org; Mon, 17 Aug 2015 03:52:09 +0000 Received: by pacgr6 with SMTP id gr6so98979655pac.2 for ; Sun, 16 Aug 2015 20:52:06 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=subject:to:references:cc:from:message-id:date:user-agent :mime-version:in-reply-to:content-type:content-transfer-encoding; bh=+drDxojSsh6Z54JGAa4Vlv1tDmpLL3VLPiknSMikaJ0=; b=RGqYLVHB8ZQPytwQ8X5MOxyexIePAwH8dtrWwr1X83EdmYdpk2GqH/ss/iKISL4RpE 4C/+fi9nqo5jUhj7H+XA62i2i+6FMIrhqHL8IqWnYLg1EkP+npxQHlhbC3cLCZakHNu8 C58lvyrEP9hk2w7CHZAfNJ7m0q4QXs6NozC0xiYpRwOAlXgBgngZBUyzyH2SKjrKiyE7 QjqF7z7r+yEaqVOBC+L1MacMSVVioe8ka3eqnrZr0KsB0o4QtXzkTOf1l9E2AM8j5pma 9gAb8gbBDzNHin5CI91Pcb1yUZ4K55sUwAnIUWXNtTSMl0oNtoBSvdx5pojU3ltpMJNm L9Jw== X-Received: by 10.66.148.6 with SMTP id to6mr112229545pab.132.1439783526679; Sun, 16 Aug 2015 20:52:06 -0700 (PDT) Received: from station12.ousa.org (nat-198-95-226-236.netapp.com. [198.95.226.236]) by smtp.googlemail.com with ESMTPSA id k8sm12627603pdn.96.2015.08.16.20.52.04 (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Sun, 16 Aug 2015 20:52:06 -0700 (PDT) Subject: Re: ERROR: cache lookup failed for type To: Tom Lane , adrian.klaver@aklaver.com References: <55D131B0.6010500@gmail.com> <15241.1439781395@sss.pgh.pa.us> Cc: "pgsql-sql@postgresql.org" From: Stuart X-Enigmail-Draft-Status: N1110 Message-ID: <55D15A62.70406@gmail.com> Date: Mon, 17 Aug 2015 07:52:02 +0400 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.2.0 MIME-Version: 1.0 In-Reply-To: <15241.1439781395@sss.pgh.pa.us> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -2.7 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org Adrian, Tom, I reloaded the database and the problem doesn't happen anymore. Thanks for the suggestion. Tom - to answer your questions, On 08/17/2015 07:16 AM, Tom Lane wrote: >> I dropped the function and can now not add it back to the database. > > What happens when you try, exactly? The same error occurred > I assume the error was persistent across multiple sessions? Have you > changed the schema (rowtype) of table documents_statistics lately? No there were no changes to the table schema. All dbase objects were loaded via pg_dumpall > file.sql upgrade postgres psql template1 -f file.sql Yes the problem was persistent across multiple sessions > Does reindexing pg_type make the error go away? If so, what platform > and filesystem is this on? No, I didn't try reindexing pg_type The filesystem is XFS Thanks, Stuart -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql