Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1ZRBkQ-0002nM-8h for pgsql-sql@arkaria.postgresql.org; Mon, 17 Aug 2015 04:10:10 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84) (envelope-from ) id 1ZRBkP-0001JR-J4 for pgsql-sql@arkaria.postgresql.org; Mon, 17 Aug 2015 04:10:09 +0000 Received: from makus.postgresql.org ([2001:4800:1501:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1ZRBjQ-0000Ck-IE for pgsql-sql@postgresql.org; Mon, 17 Aug 2015 04:09:08 +0000 Received: from out1-smtp.messagingengine.com ([66.111.4.25]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1ZRBjN-0003CE-Ss for pgsql-sql@postgresql.org; Mon, 17 Aug 2015 04:09:07 +0000 Received: from compute1.internal (compute1.nyi.internal [10.202.2.41]) by mailout.nyi.internal (Postfix) with ESMTP id 74CBF2101A for ; Mon, 17 Aug 2015 00:09:04 -0400 (EDT) Received: from frontend1 ([10.202.2.160]) by compute1.internal (MEProxy); Mon, 17 Aug 2015 00:09:04 -0400 DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=aklaver.com; h=cc :content-transfer-encoding:content-type:date:from:in-reply-to :message-id:mime-version:references:subject:to:x-sasl-enc :x-sasl-enc; s=mesmtp; bh=mMEWZPWFnjF0W/5+4dKfowAki5A=; b=ExSnEX giQcoe7Ip5RBWIMad0P171FPU8fmfMqwjIXv9hraHDK/Tpc9ZFcw9q8tnUJqzIKI Acf/DOPF7A+Gi/ME7tpHpbpTtPsSC05MsyJHIkVIB85YGPvyhyiD1MI1XZ6g4VuI NrLBxDgkD/BeFGd3R3W1t4IfGFmYC/dGC0kvY= DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d= messagingengine.com; h=cc:content-transfer-encoding:content-type :date:from:in-reply-to:message-id:mime-version:references :subject:to:x-sasl-enc:x-sasl-enc; s=smtpout; bh=mMEWZPWFnjF0W/5 +4dKfowAki5A=; b=XTri3F5ZzK3QvIurO3fR4wX2cLeGusRrw8/Crce/yeTqIGp ca7EaPHyvdXox/gD1/vHy5atRJPMZJJ/8eMblRB1IBCmI0avJzOrV18+Rsh7+cqM cXbpSBOz7mnA8un7FkQ2mqOoIbmh5TIwnMjQDuIHkNsxdMD/J93qlaDCTFN8= X-Sasl-enc: I6YWh69N7gsr62cRZ++KL/IM4zXFMH4ZfvttrqrXWkHO 1439784544 Received: from [192.168.1.3] (174-21-248-106.tukw.qwest.net [174.21.248.106]) by mail.messagingengine.com (Postfix) with ESMTPA id CC9F8C00018; Mon, 17 Aug 2015 00:09:03 -0400 (EDT) Subject: Re: ERROR: cache lookup failed for type To: Stuart , Tom Lane References: <55D131B0.6010500@gmail.com> <15241.1439781395@sss.pgh.pa.us> <55D15A62.70406@gmail.com> Cc: "pgsql-sql@postgresql.org" From: Adrian Klaver Message-ID: <55D15E47.9020007@aklaver.com> Date: Sun, 16 Aug 2015 21:08:39 -0700 User-Agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Thunderbird/38.2.0 MIME-Version: 1.0 In-Reply-To: <55D15A62.70406@gmail.com> Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -2.7 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org On 08/16/2015 08:52 PM, Stuart wrote: > Adrian, Tom, > > I reloaded the database and the problem doesn't happen anymore. > Thanks for the suggestion. > > Tom - to answer your questions, > > On 08/17/2015 07:16 AM, Tom Lane wrote: >>> I dropped the function and can now not add it back to the database. >> >> What happens when you try, exactly? > > The same error occurred > >> I assume the error was persistent across multiple sessions? Have you >> changed the schema (rowtype) of table documents_statistics lately? > > No there were no changes to the table schema. All dbase objects were > loaded via > > pg_dumpall > file.sql > > upgrade postgres > > psql template1 -f file.sql So this is what you did when you started with the Alpha 1 database, correct? When you went to Alpha 2 you just installed the new program over the existing Alpha 1, but left the data directory as is and then ran into the error, correct? You then did a dump of the Alpha 1 or other(?) existing database and then a restore into the Alpha 2(the reload above) at which point the error went away, correct? > > Yes the problem was persistent across multiple sessions > >> Does reindexing pg_type make the error go away? If so, what platform >> and filesystem is this on? > > No, I didn't try reindexing pg_type > > The filesystem is XFS > > > Thanks, > > Stuart > -- Adrian Klaver adrian.klaver@aklaver.com -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql