Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1a4X4b-0001D3-EK for pgsql-sql@arkaria.postgresql.org; Thu, 03 Dec 2015 16:49:37 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84) (envelope-from ) id 1a4X4a-0004GW-NL for pgsql-sql@arkaria.postgresql.org; Thu, 03 Dec 2015 16:49:36 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1a4X3b-0002zs-9n for pgsql-sql@postgresql.org; Thu, 03 Dec 2015 16:48:35 +0000 Received: from out4-smtp.messagingengine.com ([66.111.4.28]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1a4X3X-000579-Hn for pgsql-sql@postgresql.org; Thu, 03 Dec 2015 16:48:34 +0000 Received: from compute5.internal (compute5.nyi.internal [10.202.2.45]) by mailout.nyi.internal (Postfix) with ESMTP id 68DDA20500 for ; Thu, 3 Dec 2015 11:48:29 -0500 (EST) Received: from frontend2 ([10.202.2.161]) by compute5.internal (MEProxy); Thu, 03 Dec 2015 11:48:29 -0500 DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=aklaver.com; h= content-transfer-encoding:content-type:date:from:in-reply-to :message-id:mime-version:references:subject:to:x-sasl-enc :x-sasl-enc; s=mesmtp; bh=WnDEBzgEGchHFXjl4xF3FhcCuHQ=; b=cR9gXD Vr/p/5NumJO4G6p6hMsAvuvOEbBuEMsvAk+SFqxFhRNAo1+kmpgRpi9hyX/8yBu5 j9J+tsdfcn1S4t3RXskwCWOF9qcDh0ddOzm2A5en/X6oEk/lJsiEr36wQnh9YNQf innGlpwC8v6eDOiUGV8Y7/45QlQ0vRm7kU/oU= DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d= messagingengine.com; h=content-transfer-encoding:content-type :date:from:in-reply-to:message-id:mime-version:references :subject:to:x-sasl-enc:x-sasl-enc; s=smtpout; bh=WnDEBzgEGchHFXj l4xF3FhcCuHQ=; b=Uwv3BVVm3kOOjwZB6Jx++dDtdb79IWifjD+wgYecbmBHEvO uZbxu9rKeyVLNADO7vz5uw6Bc38H2Y7h+oNH0qxNi3N4LDjENaKLiC1lo+eMpAx7 z4z1L8SdZKe1Nxm9ptKidFbnFFJv954xOvxukFf//5NrubrXQjIFi0fmxpg8= X-Sasl-enc: REraSnYRkS+2L90WjaGq8ZopQa4z0BZSbXB2XAoee1kV 1449161309 Received: from killi.site (173-160-167-74-washington.hfc.comcastbusiness.net [173.160.167.74]) by mail.messagingengine.com (Postfix) with ESMTPA id D044D6800D3; Thu, 3 Dec 2015 11:48:28 -0500 (EST) Subject: Re: Re: ERROR while creating new user - could not open relation mapping file global/pg_filenode.map To: Sribeiro , pgsql-sql@postgresql.org References: <1449100566874-5875998.post@n5.nabble.com> <565F8951.7090505@aklaver.com> <1449102851217-5876007.post@n5.nabble.com> <565F8F44.2060200@aklaver.com> <1449103913630-5876012.post@n5.nabble.com> <565F9916.8050800@aklaver.com> <1449107178100-5876028.post@n5.nabble.com> <565FCD37.3080804@aklaver.com> <1449147608774-5876118.post@n5.nabble.com> <566060E1.6070808@aklaver.com> <1449160418085-5876161.post@n5.nabble.com> From: Adrian Klaver Message-ID: <56607275.4060404@aklaver.com> Date: Thu, 3 Dec 2015 08:48:53 -0800 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.4.0 MIME-Version: 1.0 In-Reply-To: <1449160418085-5876161.post@n5.nabble.com> Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -2.7 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org On 12/03/2015 08:33 AM, Sribeiro wrote: > 1) yes, I have a fresh install from yesterday in the /usr/local/var/postgres > directory. Yesterday there was no server.log in that directory, but today I > have a server.log in that directory. There's only one timestamp: > /LOG: database system was shut down at 2015-12-02 16:33:52 EST > LOG: MultiXact member wraparound protections are now enabled > LOG: autovacuum launcher started > LOG: database system is ready to accept connections/ > > 2) Yes, but only one server.log file with many entries/timestamps that > includes the timestamp mentioned previously. > > 3) Here is the path to the directory where the older server.log resides - > /Users/Serge/Desktop/postgres > > 4) Both installs have the pg_filenode.map inside the global directory, but How can that be? From previous posts: " Dec 02, 2015; 1:06pm Sribeiro Sribeiro This is what that directory looks like - http://postimg.org/image/olhb2zra9/ I can't find anywhere on my system (doing a search) the .map file. Thank you for clarifying the importance of that file. Since I didn't have any important information on it, can I start from scratch, and thus creating a new .map file? Sergio Dec 02, 2015; 1:44pm Sribeiro Sribeiro This post was updated on Dec 02, 2015; 1:45pm. Hi Adrian, So, i made sure to copy the postgres directory then deleted the main one as to not conflict with a fresh install. Once I got to the section in the instructions I used that says to run the - rake db:create:all I get the following error: rake db:create:all FATAL: could not open relation mapping file "global/pg_filenode.map": No such file or directory BUT, if I look in the newest postgres/global directory, the pg_filenode.map is in there. Any thoughts Sergio " Are you sure /Users/Serge/Desktop/postgres is not a link to somewhere? > when I ran the commands from yesterday, I kept getting the error message: > /psql: FATAL: could not open relation mapping file > "global/pg_filenode.map": No such file or directory / Have you tried stopping Postgres and then restarting it? > > > > -- > View this message in context: http://postgresql.nabble.com/ERROR-while-creating-new-user-could-not-open-relation-mapping-file-global-pg-filenode-map-tp5874842p5876161.html > Sent from the PostgreSQL - sql mailing list archive at Nabble.com. > > -- Adrian Klaver adrian.klaver@aklaver.com -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql