Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1aROHo-0005C3-Tc for pgsql-sql@arkaria.postgresql.org; Thu, 04 Feb 2016 18:05:45 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84) (envelope-from ) id 1aROHo-0000rG-9g for pgsql-sql@arkaria.postgresql.org; Thu, 04 Feb 2016 18:05:44 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1aROHm-0000pi-Fk for pgsql-sql@postgresql.org; Thu, 04 Feb 2016 18:05:42 +0000 Received: from out5-smtp.messagingengine.com ([66.111.4.29]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84) (envelope-from ) id 1aROHj-0000qf-Qd for pgsql-sql@postgresql.org; Thu, 04 Feb 2016 18:05:42 +0000 Received: from compute6.internal (compute6.nyi.internal [10.202.2.46]) by mailout.nyi.internal (Postfix) with ESMTP id 27097207BF for ; Thu, 4 Feb 2016 13:05:37 -0500 (EST) Received: from frontend1 ([10.202.2.160]) by compute6.internal (MEProxy); Thu, 04 Feb 2016 13:05:37 -0500 DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=aklaver.com; h=cc :content-transfer-encoding:content-type:date:from:in-reply-to :message-id:mime-version:references:subject:to:x-sasl-enc :x-sasl-enc; s=mesmtp; bh=R4+0lZ6s8vmuZ6Ja2Z4yoJvSaZI=; b=ln0/Th lfQ0OAwutfCGIVHFclzu7XXaC8TsIvLQkvZLbIHsiRcFcGVssf9qDMuL8HGRkPFE YezsBrlCOvEzLLjchAKQlZiKSHMVqbxDOcnAhZywpqk4O86AMCGwlLvfJG5XainV wyDzsjPr5JBajDoZkZmdxJuXisQjdVIwp6faY= DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d= messagingengine.com; h=cc:content-transfer-encoding:content-type :date:from:in-reply-to:message-id:mime-version:references :subject:to:x-sasl-enc:x-sasl-enc; s=smtpout; bh=R4+0lZ6s8vmuZ6J a2Z4yoJvSaZI=; b=uj8VW11HaU25poSC4eNMtmVhk+4bQTk1fCydtD5LFCbmcxY Cjnxl9MbExvjTK84lzPQPL8eMSbpZk9eenmBWBXzSzwHweWW8h1Z3CRfhyG8Thda oFndLpl/nbX8C1BMOV/Uf29kK95ti9SE8ohUce4tF5+7sTfG6gDXowVXSoxo= X-Sasl-enc: dIDaYBkAdSfwVKxXvI+j+DKM3QwhPO4Kg7sepIYJ2+be 1454609136 Received: from [192.168.1.2] (174-21-70-246.tukw.qwest.net [174.21.70.246]) by mail.messagingengine.com (Postfix) with ESMTPA id 43FBAC00013; Thu, 4 Feb 2016 13:05:36 -0500 (EST) Subject: Re: Create db fails using utility tool To: Shashank Dutt Jha References: <56B37EF8.7030904@aklaver.com> <649F207B-457F-4DC7-8770-CB5E7E467C4F@gmail.com> Cc: pgsql-sql@postgresql.org From: Adrian Klaver Message-ID: <56B392B1.3010608@aklaver.com> Date: Thu, 4 Feb 2016 10:04:33 -0800 User-Agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Thunderbird/38.5.1 MIME-Version: 1.0 In-Reply-To: <649F207B-457F-4DC7-8770-CB5E7E467C4F@gmail.com> Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -2.7 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-sql Precedence: bulk Sender: pgsql-sql-owner@postgresql.org On 02/04/2016 09:45 AM, Shashank Dutt Jha wrote: > Yes server is running on the local host and default port. I can connect to it using UI pgsql client Do you mean pgAdmin or the SQL shell command? In either case are you running createdb.exe on the same machine? What happens if you run createdb.exe with explicit options: createdb.exe -h localhost -p 5432 -U > > > >> On Feb 4, 2016, at 10:10 PM, Adrian Klaver wrote: >> >>> On 02/03/2016 11:23 PM, Shashank Dutt Jha wrote: >>> c:\Program Files\PostgreSQL\9.5\bin>createdb.exe testdb >>> createdb: could not connect to database template1: could not connect to >>> server: >>> Connection refused (0x0000274D/10061) >>> Is the server running on host "localhost" (::1) and accepting >>> TCP/IP connections on port 5432? >>> could not connect to server: Connection refused (0x0000274D/10061) >>> Is the server running on host "localhost" (127.0.0.1) and accepting >>> TCP/IP connections on port 5432? >> >> >> Well the error is pretty specific, so is the server running and if so does it have the parameters set as above? >> >> >> >> -- >> Adrian Klaver >> adrian.klaver@aklaver.com > -- Adrian Klaver adrian.klaver@aklaver.com -- Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-sql