agora inbox for pgsql-sql@postgresql.org
help / color / mirror / Atom feedImporting MySql dumped db into pgadmin
7+ messages / 4 participants
[nested] [flat]
* Importing MySql dumped db into pgadmin
@ 2013-11-24 15:49 miks87 <michele.imperiali@hotmail.it>
0 siblings, 2 replies; 7+ messages in thread
From: miks87 @ 2013-11-24 15:49 UTC (permalink / raw)
To: pgsql-sql
Hi there,
I'd like to import an entire database into pgadmin. I dumped the sql version
of it but now I can't get pgadmin to accept the file and build up the
database. I'm a newbie so probably I'm doing something wrong
Any hint?
--
View this message in context: http://postgresql.1045698.n5.nabble.com/Importing-MySql-dumped-db-into-pgadmin-tp5780055.html
Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
^ permalink raw reply [nested|flat] 7+ messages in thread
* Re: Importing MySql dumped db into pgadmin
@ 2013-11-24 16:02 Theodore Petrosky <tedpet5@yahoo.com>
parent: miks87 <michele.imperiali@hotmail.it>
1 sibling, 1 reply; 7+ messages in thread
From: Theodore Petrosky @ 2013-11-24 16:02 UTC (permalink / raw)
To: miks87 <michele.imperiali@hotmail.it>; +Cc: pgsql-sql
did you use pg_dump to create the sql? what was the exact method you used to create the dump?
if pg_dump was there compression?
On Nov 24, 2013, at 10:49 AM, miks87 <michele.imperiali@hotmail.it> wrote:
> Hi there,
> I'd like to import an entire database into pgadmin. I dumped the sql version
> of it but now I can't get pgadmin to accept the file and build up the
> database. I'm a newbie so probably I'm doing something wrong
> Any hint?
>
>
>
> --
> View this message in context: http://postgresql.1045698.n5.nabble.com/Importing-MySql-dumped-db-into-pgadmin-tp5780055.html
> Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
>
>
> --
> Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
> To make changes to your subscription:
> http://www.postgresql.org/mailpref/pgsql-sql
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
^ permalink raw reply [nested|flat] 7+ messages in thread
* Re: Importing MySql dumped db into pgadmin
@ 2013-11-24 16:08 Adrian Klaver <adrian.klaver@gmail.com>
parent: miks87 <michele.imperiali@hotmail.it>
1 sibling, 1 reply; 7+ messages in thread
From: Adrian Klaver @ 2013-11-24 16:08 UTC (permalink / raw)
To: miks87 <michele.imperiali@hotmail.it>; pgsql-sql
On 11/24/2013 07:49 AM, miks87 wrote:
> Hi there,
> I'd like to import an entire database into pgadmin. I dumped the sql version
> of it but now I can't get pgadmin to accept the file and build up the
> database. I'm a newbie so probably I'm doing something wrong
> Any hint?
What program did you use to dump the MySQL db and what parameters did
you use?
Define pgadmin did not accept.
How did you use pgadmin to execute the file?
Did it throw an error and if so what was the error?
>
>
>
> --
> View this message in context: http://postgresql.1045698.n5.nabble.com/Importing-MySql-dumped-db-into-pgadmin-tp5780055.html
> Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
>
>
--
Adrian Klaver
adrian.klaver@gmail.com
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
^ permalink raw reply [nested|flat] 7+ messages in thread
* Re: Importing MySql dumped db into pgadmin
@ 2013-11-24 16:11 miks87 <michele.imperiali@hotmail.it>
parent: Theodore Petrosky <tedpet5@yahoo.com>
0 siblings, 0 replies; 7+ messages in thread
From: miks87 @ 2013-11-24 16:11 UTC (permalink / raw)
To: pgsql-sql
I'm using phpMyAdmin and I don't see any option to export using pg_dump.
--
View this message in context: http://postgresql.1045698.n5.nabble.com/Importing-MySql-dumped-db-into-pgadmin-tp5780055p5780060.htm...
Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
^ permalink raw reply [nested|flat] 7+ messages in thread
* Re: Importing MySql dumped db into pgadmin
@ 2013-11-24 16:21 miks87 <michele.imperiali@hotmail.it>
parent: Adrian Klaver <adrian.klaver@gmail.com>
0 siblings, 2 replies; 7+ messages in thread
From: miks87 @ 2013-11-24 16:21 UTC (permalink / raw)
To: pgsql-sql
Hi Adrian, thanks for your answer. I'm using the export wizard from within
phpmyadim and I'm exporting in SQL. Then I'm simply trying to execute the
SQL code within pgAdmin but I get several errors in the code: a few examples
are the use of "AUTO_INCREMENT" or also check conditions on table attributes
(I get error on the clause ON). Also I get error when integer attributes are
specified with the notazion int(maxlength)...
--
View this message in context: http://postgresql.1045698.n5.nabble.com/Importing-MySql-dumped-db-into-pgadmin-tp5780055p5780061.htm...
Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
^ permalink raw reply [nested|flat] 7+ messages in thread
* Re: Importing MySql dumped db into pgadmin
@ 2013-11-24 16:37 Jan Lentfer <Jan.Lentfer@web.de>
parent: miks87 <michele.imperiali@hotmail.it>
1 sibling, 0 replies; 7+ messages in thread
From: Jan Lentfer @ 2013-11-24 16:37 UTC (permalink / raw)
To: miks87 <michele.imperiali@hotmail.it>; pgsql-sql
Hi,
it won't work that way because mysql is just too different. You might want to look at the latest version of pgloader.
Regards
Jan
miks87 <michele.imperiali@hotmail.it> schrieb:
>Hi Adrian, thanks for your answer. I'm using the export wizard from
>within
>phpmyadim and I'm exporting in SQL. Then I'm simply trying to execute
>the
>SQL code within pgAdmin but I get several errors in the code: a few
>examples
>are the use of "AUTO_INCREMENT" or also check conditions on table
>attributes
>(I get error on the clause ON). Also I get error when integer
>attributes are
>specified with the notazion int(maxlength)...
>
>
>
>--
>View this message in context:
>http://postgresql.1045698.n5.nabble.com/Importing-MySql-dumped-db-into-pgadmin-tp5780055p5780061.htm...
>Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
>
>
>--
>Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
>To make changes to your subscription:
>http://www.postgresql.org/mailpref/pgsql-sql
--
Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail gesendet.
^ permalink raw reply [nested|flat] 7+ messages in thread
* Re: Importing MySql dumped db into pgadmin
@ 2013-11-24 17:06 Adrian Klaver <adrian.klaver@gmail.com>
parent: miks87 <michele.imperiali@hotmail.it>
1 sibling, 0 replies; 7+ messages in thread
From: Adrian Klaver @ 2013-11-24 17:06 UTC (permalink / raw)
To: miks87 <michele.imperiali@hotmail.it>; pgsql-sql
On 11/24/2013 08:21 AM, miks87 wrote:
> Hi Adrian, thanks for your answer. I'm using the export wizard from within
> phpmyadim and I'm exporting in SQL. Then I'm simply trying to execute the
> SQL code within pgAdmin but I get several errors in the code: a few examples
> are the use of "AUTO_INCREMENT" or also check conditions on table attributes
> (I get error on the clause ON). Also I get error when integer attributes are
> specified with the notazion int(maxlength)...
Yea, as previously noted that will not work.
Some docs:
https://wiki.postgresql.org/wiki/Converting_from_other_Databases_to_PostgreSQL#MySQL
Per the pgloader suggestion take a look at this blog from the author:
http://tapoueh.org/blog/2013/11/12-migrating-sakila
>
>
>
> --
> View this message in context: http://postgresql.1045698.n5.nabble.com/Importing-MySql-dumped-db-into-pgadmin-tp5780055p5780061.htm...
> Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
>
>
--
Adrian Klaver
adrian.klaver@gmail.com
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
^ permalink raw reply [nested|flat] 7+ messages in thread
end of thread, other threads:[~2013-11-24 17:06 UTC | newest]
Thread overview: 7+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2013-11-24 15:49 Importing MySql dumped db into pgadmin miks87 <michele.imperiali@hotmail.it>
2013-11-24 16:02 ` Theodore Petrosky <tedpet5@yahoo.com>
2013-11-24 16:11 ` miks87 <michele.imperiali@hotmail.it>
2013-11-24 16:08 ` Adrian Klaver <adrian.klaver@gmail.com>
2013-11-24 16:21 ` miks87 <michele.imperiali@hotmail.it>
2013-11-24 16:37 ` Jan Lentfer <Jan.Lentfer@web.de>
2013-11-24 17:06 ` Adrian Klaver <adrian.klaver@gmail.com>
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox