Subject: Long running processes and commit writing to disk

From: Shaozhong SHI <[email-masked]>
Date: Fri, 8 Apr 2022 17:39:18 +0100

When long running processes got disrupted, one may not see any expected
result.

How to make sure that the result of each operation is saved to disk in a
loop?

Regards,

David

---

From: Shaozhong SHI <[email-masked]>
Date: Fri, 8 Apr 2022 17:39:50 +0100

Regards,

David

---

From: "Mike Sofen" <[email-masked]>
Date: Fri, 8 Apr 2022 09:52:23 -0700

From: Shaozhong SHI <[email-masked]>   Sent: Friday, April 08, 2022 9:39 AM

When long running processes got disrupted, one may not see any expected result.

How to make sure that the result of each operation is saved to disk in a loop?

Regards,

David

Simple:  don’t use a database – you’re asking to violate ACID.  

A database’s power comes from set-based operations.  You’re asking to do single row operations.  Use a spreadsheet...or a plain text file and treat it like a log.

Mike

---

From: Rob Sargent <[email-masked]>
Date: Fri, 8 Apr 2022 11:05:08 -0600

On 4/8/22 10:52, Mike Sofen wrote:
>
> *From:* Shaozhong SHI <[email-masked]> *Sent:* Friday, April 
> 08, 2022 9:39 AM
>
> A database’s power comes from set-based operations.  You’re asking to 
> do single row operations.  Use a spreadsheet...or a plain text file 
> and treat it like a log.
>
> Mike
>
Or commit every loop (perhaps every N loops, depending on how much 
you're prepared to re-do.)

---

From: Ron <[email-masked]>
Date: Fri, 8 Apr 2022 13:01:23 -0500

> How to make sure that the result of each operation is saved to disk in a loop?

That would of course depend on how often you begin and commit transactions.

-- 
Angular momentum makes the world go 'round.