Subject: Very odd message

From: Shaozhong SHI <[email-masked]>
Date: Tue, 8 Aug 2023 23:13:54 +0100

server closed the connection unexpectedly
        This probably means the server terminated abnormally
        before or while processing the request.
The connection to the server was lost. Attempting reset: Failed.

This occurs every time when a particular record to be inserted into the
database.  The error message does not make sense.

Regards,

David

---

From: Erik Brandsberg <[email-masked]>
Date: Tue, 8 Aug 2023 18:17:21 -0400

Your postgres process is likely crashing.  Look for core dumps or look for
error logs.