Subject: Using Transaction with if-else in prepared statement

From: Hui Jackson <[email-masked]>
Date: Wed, 25 May 2022 19:12:49 +0800

I am trying to make transaction in nodejs
The logic will be check if sufficient coin in sender's amount, if
sufficient then do transaction.
I am new to postgres, not sure if this is a right way to do so, if you have
a better solution, please let me know, thank you.

const coin = 10
const senderId = 1
const receiverId = 2
await pgPool.query(`
DO $$
    BEGIN
        if (SELECT coin from app_user where id = $1) >= $3 THEN
            UPDATE app_user set coin = coin - $3 where id = $1;
            UPDATE app_user set coin = coin + $3 where id = $2;
            INSERT INTO coin_history(sender_id, receiver_id, amount) VALUES
($1, $2, $3)

        END IF;
    END;
$$`,[senderId, receiverId, coin]);

Error (node:10044) UnhandledPromiseRejectionWarning: error: bind message
supplies 3 parameters, but prepared statement "" requires 0

---

From: Steve Midgley <[email-masked]>
Date: Wed, 25 May 2022 11:03:34 -0700

On Wed, May 25, 2022 at 4:13 AM Hui Jackson <[email-masked]> wrote:

> I am new to postgres, not sure if this is a right way to do so, if you
> have a better solution, please let me know, thank you.
>
> const coin = 10
> const senderId = 1
> const receiverId = 2
> await pgPool.query(`
> DO $$
>     BEGIN
>             INSERT INTO coin_history(sender_id, receiver_id, amount)
> VALUES ($1, $2, $3)
>
>         END IF;
>     END;

For debugging, you might try to sending each select, update, and insert in
separate NodeJS query statements. You can do the IF work in NodeJS via a
select for data from Pg.

But at the core of your problem I believe is that you are not configuring
the postgres statement to receive parameters, but your injecting parameters
from Node. From the Pg docs on prepared statements:
https://www.postgresql.org/docs/current/sql-prepare.html

PREPARE fooplan (int, text, bool, numeric) AS
    INSERT INTO foo VALUES($1, $2, $3, $4);
EXECUTE fooplan(1, 'Hunter Valley', 't', 200.00);

---

From: hubert depesz lubaczewski <[email-masked]>
Date: Thu, 26 May 2022 01:35:56 +0200

> a better solution, please let me know, thank you.

I would do i by issuing *only*
INSERT INTO coin_history(sender_id, receiver_id, amount) VALUES
and then changing coin data with triggers plus adding constraints that
app_user.coin can never be < 0.

depesz

---

From: Hui Jackson <[email-masked]>
Date: Thu, 26 May 2022 18:00:49 +0800

Concluded both methods shared:
1.  one query per each call for using prepared statement
await pgPool.query('BEGIN;');
const sender = (await pgPool.query('SELECT coin from app_user where id =
$1;',[senderId])).rows[0];
if(sender.coin >= amount){
  await pgPool.query('UPDATE app_user set coin = coin - $1 where id = $2;',[
coin, senderId]);
  await pgPool.query('UPDATE app_user set coin = coin + $1 where id = $2;',[
coin, receiverId]);
  await pgPool.query('INSERT INTO coin_history(sender_id, receiver_id,
amount) VALUES ($1, $2, $3)',[senderId, receiverId, coin]);
  await pgPool.query('COMMIT;');
}else{
  await pgPool.query('END;');
}
2. Use constraint

CREATE TABLE app_user(
    id integer,
    coin numeric CHECK (coin >= 0)
);

hubert depesz lubaczewski <[email-masked]> 於 2022年5月26日週四 上午7:35寫道：

> have