Subject: Finding out types of error

From: Shaozhong SHI <[email-masked]>
Date: Sat, 8 Jul 2023 19:55:35 +0100

Having the following:

Begin

   insert into a_table select * from a_function

Exception
   Raise note 'Skipped"

This works.

Can it trap types of errors to find out what is wrong

Regards,

David

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 8 Jul 2023 11:58:52 -0700

> Can it trap types of errors to find out what is wrong
That is what "condition" is for.
https://www.postgresql.org/docs/current/plpgsql-control-structures.html#PLPGSQL-ERROR-TRAPPING

David J.