Subject: Recursive query - ERROR: invalid memory alloc request size 1073741824

From: Shaozhong SHI <[email-masked]>
Date: Sat, 7 May 2022 14:23:53 +0100

There is a loop of recursive query.  It runs at a point where it stops.

This error turned up.- ERROR:  invalid memory alloc request size 1073741824

Can anyone provide pointers how to solve this problem or work around?

Regards,

David

---

From: Rob Sargent <[email-masked]>
Date: Sat, 7 May 2022 07:53:11 -0600

On 5/7/22 07:23, Shaozhong SHI wrote:
> This error turned up.- ERROR:  invalid memory alloc request size 
> 1,073,741,824
>
Quite difficult without any code snippet (or even which language) but 
you've requested a single block of memory that is larger than the 
maximum allowed. That number (1,073,741,824) is 2^30 .

---

From: Tom Lane <[email-masked]>
Date: Sat, 07 May 2022 11:19:37 -0400

> This error turned up.- ERROR:  invalid memory alloc request size 1073741824

Might be a bug, but with no details it's impossible to tell.

https://wiki.postgresql.org/wiki/Guide_to_reporting_problems

			regards, tom lane

---

From: Simon Riggs <[email-masked]>
Date: Sun, 8 May 2022 20:15:54 +0100

> Can anyone provide pointers how to solve this problem or work around?

For both recursive and non-recursive queries its possible to write a
query with mistakes in it that will run for a long time or run out of
resources.

Find the mistakes in your query by simplifying it.

-- 
Simon Riggs                http://www.EnterpriseDB.com/