Subject: Can we generate a series of tables in a loop and then use another loop to union all?

From: Shaozhong SHI <[email-masked]>
Date: Thu, 13 Oct 2022 16:44:39 +0100

Can we do the following?

for j in 1..max loop
create table j as select .............
end loop;

Then,  We do

Alternatively, can we generate an empty table and append each newly
generated table to it so that we end up with a whole table?

Regards,

David

---

From: Frank Gard <[email-masked]>
Date: Thu, 13 Oct 2022 18:50:02 +0200

Hi,

you can use PL/pgSQL's "EXECUTE" to do such things.

Cheers,
Frank.

Am 13.10.22 um 17:44 schrieb Shaozhong SHI:
> Alternatively, can we generate an empty table and append each newly generated table to it so that we end up with a whole table?
>
> Regards,
>
> David