Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1iD9nP-0004SW-Lr for pgsql-sql@arkaria.postgresql.org; Wed, 25 Sep 2019 16:05:39 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1iD9nO-0007Kn-8u for pgsql-sql@arkaria.postgresql.org; Wed, 25 Sep 2019 16:05:38 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1iD9nN-0007Ke-US for pgsql-sql@lists.postgresql.org; Wed, 25 Sep 2019 16:05:38 +0000 Received: from mail-pl1-x641.google.com ([2607:f8b0:4864:20::641]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1iD9nH-00061n-Gx for pgsql-sql@lists.postgresql.org; Wed, 25 Sep 2019 16:05:37 +0000 Received: by mail-pl1-x641.google.com with SMTP id u20so2658575plq.4 for ; Wed, 25 Sep 2019 09:05:31 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; h=subject:to:references:from:message-id:date:user-agent:mime-version :in-reply-to:content-language; bh=HztePAKCdD+AeA8IOZUoNZrZJCITbiDYZRihkX4zbks=; b=DsUTOLEJ8e0xbtZ9G7MP9m2qoMN37G6ySHl1g0e3wEUPvPJOYAQjV5kJkXHwpEiPs0 Ppzek+hlHtnfHP8SYjSmZbDJidu392vgoGd516mENkMR81XPsnbueYHIvFePD8w9OrvY BckFCcpM8WJtqqX0QetbZB3BA1L33uD1reLW0sktnjt+S8w1gXVt1P4/ZpELUfcLo0h4 CAH8hR14gtC2tG04lbZZ1KlSzeN7Pr3/sdI7b7nl2gOJtqJUXcla1H6cxLJlnYl2zrIp vxJpwST1uX2gaZ0men4TG+3gOcuX/4tDkbOVnciLZl/z60pc0EGoUuiZIuV/X0nbuaRF Rz8g== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:subject:to:references:from:message-id:date :user-agent:mime-version:in-reply-to:content-language; bh=HztePAKCdD+AeA8IOZUoNZrZJCITbiDYZRihkX4zbks=; b=MBqAHV5UW1v4CEeWqTcsyuHPuDzrGYayfJWy+W/mcLKKYY0QZ8VO8zJikK52Y74Jgm zqjyX+HIGWPznDdRAAv5J6MB6Vk591jISaf3yu1jEw4I+EelUkjjuBUyT6x+Xhi3qjJD QmaapyYUB1te6ah2z/PX+FzFFMPbkd86LNqjtzM1e1zjRyKQGNeSmA0FaRGmgis9wBgZ BZFyO7SDN0AX9s5mmxJ4+GVDZHgJcUgGmWA07giXQgr8I87gzYkXO3LjIHhMREfzUanH +f9AUeBSVM+effhOBB+h9snahw4QWbZFByT0L8pOivCxZ7lK4+/LaTHWcaGWmRmJdVxa TBTw== X-Gm-Message-State: APjAAAWo2dMKO1TimwfKljg7wc9W9dsiVIgE15QgQeNSlOZ+cpuW2EJr WQU/wLgfo9Kfx2IdsFrUMHLPdSzTd54= X-Google-Smtp-Source: APXvYqy1e96wHaHucQdLnIWXqRwvdksmLhTPoWC0BMlg4sXcKseUdTtvcP4S19BsOM1TOdTuppwJpQ== X-Received: by 2002:a17:902:bd41:: with SMTP id b1mr10112808plx.174.1569427527459; Wed, 25 Sep 2019 09:05:27 -0700 (PDT) Received: from [10.104.134.41] ([155.100.47.1]) by smtp.gmail.com with ESMTPSA id ce16sm3495419pjb.29.2019.09.25.09.05.26 for (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Wed, 25 Sep 2019 09:05:27 -0700 (PDT) Subject: Re: Fw: How do I get rid of version 10 Postgresql completely ? To: pgsql-sql@lists.postgresql.org References: <1919730995.8525624.1569423809969@mail.yahoo.com> <883209789.8574151.1569426731361@mail.yahoo.com> From: Rob Sargent Message-ID: Date: Wed, 25 Sep 2019 10:05:25 -0600 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.8.0 MIME-Version: 1.0 In-Reply-To: <883209789.8574151.1569426731361@mail.yahoo.com> Content-Type: multipart/alternative; boundary="------------584E3CC31F7A52A14827F37B" Content-Language: en-US List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk This is a multi-part message in MIME format. --------------584E3CC31F7A52A14827F37B Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 8bit On 9/25/19 9:52 AM, Karen Goh wrote: > Hello, > > Here's some more information to show the system still containing the > uninstalled version 10: > > root@DESKTOP-1KGGO27:~# sudo service postgresql start * Error: > /usr/lib/postgresql/10/bin/pg_ctl /usr/lib/postgresql/10/bin/pg_ctl > start -D /var/lib/postgresql/10/main -l > /var/log/postgresql/postgresql-10-main.log -s -o -c > config_file="/etc/postgresql/10/main/postgresql.conf" exited with > status 1: > 2019-09-25 23:49:04.217 +08 [116] LOG: could not bind IPv4 address > "127.0.0.1": Permission denied > 2019-09-25 23:49:04.217 +08 [116] HINT: Is another postmaster already > running on port 5433? If not, wait a few seconds and retry. > 2019-09-25 23:49:04.217 +08 [116] WARNING: could not create listen > socket for "localhost" > 2019-09-25 23:49:04.218 +08 [116] FATAL: could not create any TCP/IP > sockets > 2019-09-25 23:49:04.294 +08 [116] LOG: database system is shut down > pg_ctl: could not start server > Examine the log output. > > Hope someone can tell me how to get rid of it completely. > > Tks. > Karen, Those look like linux commands?  Are you removing postgres from "DESKTOP-1KGG027"?  Try ps elf | grep postgres to see the running postgres processes. sudo service postgresql stop should stop the running instance cat /etc/os-release to see what os is running, if you're unsure.  Do you know how postgres was installed? (Maybe apt or yum or similar?) --------------584E3CC31F7A52A14827F37B Content-Type: text/html; charset=utf-8 Content-Transfer-Encoding: 8bit


On 9/25/19 9:52 AM, Karen Goh wrote:
Hello,

Here's some more information to show the system still containing the uninstalled version 10:

root@DESKTOP-1KGGO27:~# sudo service postgresql start * Error: /usr/lib/postgresql/10/bin/pg_ctl /usr/lib/postgresql/10/bin/pg_ctl start -D /var/lib/postgresql/10/main -l /var/log/postgresql/postgresql-10-main.log -s -o -c config_file="/etc/postgresql/10/main/postgresql.conf" exited with status 1:
2019-09-25 23:49:04.217 +08 [116] LOG: could not bind IPv4 address "127.0.0.1": Permission denied
2019-09-25 23:49:04.217 +08 [116] HINT: Is another postmaster already running on port 5433? If not, wait a few seconds and retry.
2019-09-25 23:49:04.217 +08 [116] WARNING: could not create listen socket for "localhost"
2019-09-25 23:49:04.218 +08 [116] FATAL: could not create any TCP/IP sockets
2019-09-25 23:49:04.294 +08 [116] LOG: database system is shut down
pg_ctl: could not start server
Examine the log output.

Hope someone can tell me how to get rid of it completely.

Tks.

Karen,

Those look like linux commands?  Are you removing postgres from "DESKTOP-1KGG027"?  Try

ps elf | grep postgres

to see the running postgres processes.

sudo service postgresql stop

should stop the running instance

cat /etc/os-release

to see what os is running, if you're unsure.  Do you know how postgres was installed? (Maybe apt or yum or similar?)


--------------584E3CC31F7A52A14827F37B--