Subject: translation typos spanish

From: Justin Pryzby <[email-masked]>
Date: Mon, 17 Oct 2022 15:28:09 -0500

Como proyecto mientras aprendido español, he buscado para errores...

tieneline => timeline
pg_read_all settings => pg_read_all_settings
remanentde => remanente
particionaiento => particionamiento
nomre => nombre 
identificadoes => identificadores
estæ => esta
izquiero => izquierdo 
coincidenete => coincidente
dedujeron => deducieron ??

Hay palabras que están faltando de acentos:
replicacion
restriccion
combinacion

Hay pocos palabras inglés que no estan traducido:

object => objeto
schema => esquema
arguments => argumentos
and => y
distinguished name => nombre distinguido

src/backend/po/es.po:msgstr "object de estadísticas %s"
src/backend/po/es.po:msgstr "el nombre de schema «%s» es inaceptable"
src/backend/po/es.po:msgstr "no está permitido invocar procedimientos con arguments de salida en funciones SQL"
src/backend/po/es.po:msgstr "Esto puede indicar que el cliente no soporta ninguna versión del protocolo SSL entre %s and %s."
src/interfaces/libpq/po/es.po:msgstr "URL LDAP no válida «%s»: distinguished name faltante\n"

También, tal vez "tokens" debe ser "testigo" (tambien en otras fichas .po):

src/backend/po/es.po-msgid "cannot create restricted tokens on this platform: error code %lu"
src/backend/po/es.po:msgstr "no se pueden crear tokens restrigidos en esta plataforma: código de error %lu"

---

From: Alvaro Herrera <[email-masked]>
Date: Wed, 19 Oct 2022 19:19:03 +0200

> Hay pocos palabras inglés que no estan traducido:

¡Gracias!  He corregido todos estos errores (y unos pocos más que he
visto mientras los buscaba), aunque sólo en la rama master, que aún
necesita bastante trabajo más de traducción.  Me pregunto si habrá
alguna herramienta estilo 'ispell' para archivos .po ...

> distinguished name => nombre distinguido

I'm unsure about translating this term, as the message would become more
obscure, whereas keeping it like this helps somebody who knows the LDAP
terminology.  I see some other catalogs use the term without translation
probably for that reason:

msgid "invalid LDAP URL \"%s\": missing distinguished name\n"
msgstr "ungültige LDAP-URL »%s«: Distinguished Name fehlt\n"

msgid "invalid LDAP URL \"%s\": missing distinguished name\n"
msgstr "URL LDAP « %s » invalide : le « distinguished name » manque\n"

msgid "invalid LDAP URL \"%s\": missing distinguished name\n"
msgstr "URL LDAP \"%s\" non corretta: distinguished name non trovato\n"

(Funny all those different quoting styles.  I do wish French used
non-breaking spaces between the quote sign and the quoted contend ...)

> src/backend/po/es.po:msgstr "no se pueden crear tokens restrigidos en esta plataforma: código de error %lu"

Unsure about this one also.  Some languages keep "restricted" without
translation, others keep "token", and Turkish does this

msgid "could not create restricted token: error code %lu"
msgstr "kısıtlı andaç (restricted token) oluşturulamadı: hata kodu %lu"

I think for such a fringe message, it's not worth trying to explain the
term too much ...  but we have the word "token" in a bunch other
messages, so perhaps it's worth uniforming and clarifying.

-- 
Álvaro Herrera        Breisgau, Deutschland  —  https://www.EnterpriseDB.com/
"Escucha y olvidarás; ve y recordarás; haz y entenderás" (Confucio)

---

From: Alvaro Herrera <[email-masked]>
Date: Thu, 20 Oct 2022 09:12:46 +0200

> dedujeron => deducieron ??

Perdón, olvidé comentar este.  No es un typo, es la conjugación
correcta, porque "deducir" es un verbo irregular (tal como decir -> dijeron)

Saludos,

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/
"Hay que recordar que la existencia en el cosmos, y particularmente la
elaboración de civilizaciones dentro de él no son, por desgracia,
nada idílicas" (Ijon Tichy)