Subject: First Author?

From: Georgios <[email-masked]>
Date: Mon, 24 May 2021 09:49:42 +0000

Hi,

I am very happy to see that several of my translation
attempts are now part of the code base.

However they all lack First Author information. I had
not filled in that one as I felt it was not my place
to do so although in retrospect I should have asked
first. I had filled the email field though to make the
committer's life easier.

As an example in the el po files the following will
be found:

# Copyright (C) 2021 PostgreSQL Global Development Group
# This file is distributed under the same license as the psql (PostgreSQL) package.
#
msgid ""

Whereas it is common to find a first author reference as

# Copyright (C) 2009 - 2019 PostgreSQL Global Development Group
# This file is distributed under the same license as the PostgreSQL package.
# Peter Eisentraut <[email-masked]>, 2009 - 2019.
msgid ""

Would it be unreasonable to ask to be added as first
author in the files that have been committed so far?

Cheers,
//Georgios

---

From: Guillaume Lelarge <[email-masked]>
Date: Mon, 24 May 2021 15:55:25 +0200

Hi,

> author in the files that have been committed so far?
Why don't you do it yourself? if you did the work, I see no harm in fixing
this yourself ;) (FWIW, I did this myself in the french .po files)

-- 
Guillaume.

---

From: [email-masked]
Date: Mon, 24 May 2021 14:14:24 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Monday, 24 May 2021 15:55, Guillaume Lelarge <[email-masked]> wrote:

> Why don't you do it yourself? if you did the work, I see no harm in fixing this yourself ;) (FWIW, I did this myself in the french .po files)

Yeah, I can do it myself for sure. I am still trying to figure out
protocol on these matters, hence I ask first.

I will add the updated files in redmine.

//Georgios

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 25 May 2021 13:28:48 +0200

> first. I had filled the email field though to make the

The tools that generate these template files produce a bunch of things 
that we don't really need.  So feel free to set it up as you want.  But 
if you choose to not fill it in, don't just leave the template there, 
just delete it.

Personally, I am now leaning toward trimming the header comments to a 
minimum.  Authorship tracking etc. can be done via Git.

---

From: [email-masked]
Date: Fri, 28 May 2021 14:16:52 +0000

> if you choose to not fill it in, don't just leave the template there,

Got it, thanks!

> minimum. Authorship tracking etc. can be done via Git.

Right, this sounds reasonable. However this is not currently the case,
is it? For example, the commit that first introduced libpq's el.po, namely
6206454bda, does not contain any authorship information.

---

From: Peter Eisentraut <[email-masked]>
Date: Mon, 31 May 2021 21:02:07 +0200

> 6206454bda, does not contain any authorship information.

The commit message links to the translation repository, and the commit 
there links to the redmine ticket.