Subject: bug in polish translation

From: Realizacja Casa Dinero <[email-masked]>
Date: Tue, 16 Jan 2024 11:58:38 +0100

Hello,

we would like to report, that in polish translation of "createdb --help" 
((PostgreSQL) 16.1 MANJARO LINUX) manual there is a mistake:

-p, --port=PORT              numer portu na serwera bazy dnayc

Last word should be "danych"

Thanks,

Paweł Rosiński

FullStack

Casa Dinero Sp. z o.o.

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 16 Jan 2024 14:38:47 +0100

Forwarding this to the translation list where it has a greater chance of being
seen by the team translating into Polish.

> Begin forwarded message:
> 
> From: Realizacja Casa Dinero <[email-masked]>
> Subject: bug in polish translation
> Date: 16 January 2024 at 11:58:38 CET
> To: [email-masked]
> Message-Id: <[email-masked]>
> 
> Hello,
> 
> we would like to report, that in polish translation of "createdb --help" ((PostgreSQL) 16.1 MANJARO LINUX) manual there is a mistake:
> 
> 
> 

--
Daniel Gustafsson

---

From: Realizacja Casa Dinero <[email-masked]>
Date: Tue, 16 Jan 2024 16:57:12 +0100

-------- Wiadomość oryginalna --------

  		TEMAT:
  		Fwd: bug in polish translation

  		DATA:
  		2024-01-16 14:38

  		OD:
  		Daniel Gustafsson <[email-masked]>

  		DO:
  		[email-masked]

  		KOPIA:
  		[email-masked]

Forwarding this to the translation list where it has a greater chance of 
being
seen by the team translating into Polish.

> we would like to report, that in polish translation of "createdb 
> --help" ((PostgreSQL) 16.1 MANJARO LINUX) manual there is a mistake:
> 

--
Daniel Gustafsson

---

From: Alvaro Herrera <[email-masked]>
Date: Tue, 16 Jan 2024 19:27:11 +0100

> seen by the team translating into Polish.

Thanks.

> > Last word should be "danych"

Hmm, I see this message is translated in several files, and it's not
translated consistently -- but they all consistently contain the same typo:

pg_basebackup.po-msgid "  -p, --port=PORT        database server port number\n"
pg_basebackup.po:msgstr "  -p, --port=PORT          numer portu na serwera bazy dnaych\n"
--
pg_dump.po-msgid "  -p, --port=PORT          database server port number\n"
pg_dump.po:msgstr "  -p, --port=PORT          numer portu na serwera bazy dnaych\n"
--
pgscripts.po-msgid "  -p, --port=PORT           database server port\n"
pgscripts.po:msgstr "  -p, --port=PORT           numer portu na serwera bazy dnaych\n"
--
pgscripts.po-msgid "  -p, --port=PORT              database server port\n"
pgscripts.po:msgstr "  -p, --port=PORT              numer portu na serwera bazy dnaych\n"
--
pgscripts.po-msgid "  -p, --port=PORT          database server port\n"
pgscripts.po:msgstr "  -p, --port=PORT          portu na serwerze bazy dnaych\n"

(It's a bit weird that the English sentences are also different.  Maybe we
should fix that too.)

Anyway, it's hard to get too excited about this, given that it's been
abandoned since 2017.

-- 
Álvaro Herrera         PostgreSQL Developer  —  https://www.EnterpriseDB.com/

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 16 Jan 2024 13:46:04 -0500

On Tue, Jan 16, 2024 at 11:58:38AM +0100, Realizacja Casa Dinero wrote:
> Hello,
> 
> we would like to report, that in polish translation of "createdb --help" (
> (PostgreSQL) 16.1 MANJARO LINUX) manual there is a mistake:
> 
> 

Please report this to [email-masked], thanks.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 20 Jan 2024 09:03:02 +0100

> Last word should be "danych"

Thanks, a fix has been committed and will be in the next update release.

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 20 Jan 2024 09:05:24 +0100

> Anyway, it's hard to get too excited about this, given that it's been

I have fixed it in master.  For some reason that is not quite clear to 
me right now, these files are shipped in PostgreSQL 16 (which is where 
the bug report came from) (but not <=PG15), so it's appropriate to fix 
it for the next minor release.