Subject: check alignment of --help output

From: Peter Eisentraut <[email-masked]>
Date: Thu, 16 Sep 2021 13:40:02 +0200

I just checked the alignment of the translated --help output and fixed a 
few mistakes.  But some translations were all over the place, so I 
didn't feel like messing with that.  Please check, for example with

export LANG=...
for x in $prefix/bin/*; do $x --help; done | less

and make it look nice. :)

---

From: [email-masked]
Date: Thu, 16 Sep 2021 11:58:33 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

> didn't feel like messing with that. Please check, for example with

Thank you for looking Peter

> and make it look nice. :)

please find translation amendments, alignment fixes, and file additions
for Hellenic in issue tracker. [1]

Cheers,
//Georgios

[1] https://redmine.postgresql.org/issues/6676

---

From: Alexander Lakhin <[email-masked]>
Date: Fri, 17 Sep 2021 08:45:00 +0300

Hello Peter,
16.09.2021 14:40, Peter Eisentraut wrote:
> I just checked the alignment of the translated --help output and fixed
> a few mistakes.  But some translations were all over the place, so I
Russian translation is fixed now. Thanks for taking care of this!

And while in moving to nice look, I would like to note that the new
pg_amcheck' help looks different from others in using "NOT".
  -a, --all                       check all databases
  -d, --database=PATTERN          check matching database(s)
  -D, --exclude-database=PATTERN  do NOT check matching database(s)
  -i, --index=PATTERN             check matching index(es)
  -I, --exclude-index=PATTERN     do NOT check matching index(es)
  -r, --relation=PATTERN          check matching relation(s)
  -R, --exclude-relation=PATTERN  do NOT check matching relation(s)
  -s, --schema=PATTERN            check matching schema(s)
vs
  --no-comments                do not dump comments
  --no-publications            do not dump publications
  --no-security-labels         do not dump security label assignments
  --no-subscriptions           do not dump subscriptions
  --no-synchronized-snapshots  do not use synchronized snapshots in
parallel jobs
  --no-tablespaces             do not dump tablespace assignments
  --no-toast-compression       do not dump TOAST compression methods
  --no-unlogged-table-data     do not dump unlogged table data

Is this emphasis appropriate?

Best regards,
Alexander

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 17 Sep 2021 11:03:51 +0200

> Is this emphasis appropriate?

I think it could be removed.