Subject: Italian translations being dropped for 15

From: Thom Brown <[email-masked]>
Date: Wed, 7 Sep 2022 16:39:23 +0100

Hi,

I noticed that Italian translations for core are being dropped for 15
at this point in time.  As it stands, it has reached 78%, just short
of the 80% requirement.  As it's so close, is someone available to get
this completed?

Thanks

Thom

---

From: Domenico Sgarbossa <[email-masked]>
Date: Wed, 07 Sep 2022 19:16:21 +0200

Hi, I'm interested.

Where can I get core translations?

Il 7 set 2022 17:39, Thom Brown <[email-masked]> ha scritto:

Hi,

this completed?

Thanks

Thom

---

From: Thom Brown <[email-masked]>
Date: Wed, 7 Sep 2022 18:35:41 +0100

> Where can I get core translations?

Great.  Details can be found on the wiki: https://wiki.postgresql.org/wiki/NLS

I'm pretty sure that no one else is working on it, but just in case,
I've cc'd Daniele Varazzo who worked on it previously.

Thom

---

From: Domenico Sgarbossa <[email-masked]>
Date: Wed, 07 Sep 2022 21:13:41 +0200

Ok, so if Daniele is agree I will proceed.

I guess I should notice Jonathan.

Just one thing: I cannot understand which is the due date ...

Il 7 set 2022 19:35, Thom Brown <[email-masked]> ha scritto:

On Wed, 7 Sept 2022 at 18:18, Domenico Sgarbossa <[email-masked]> wrote:

Thom

---

From: Peter Eisentraut <[email-masked]>
Date: Thu, 8 Sep 2022 14:00:34 +0200

> Just one thing: I cannot understand which is the due date ...

We would usually be cleaning stale translations when the first release 
candidate is prepared, which is probably in a few weeks.

---

From: Alvaro Herrera <[email-masked]>
Date: Sun, 25 Sep 2022 21:44:20 +0200

> candidate is prepared, which is probably in a few weeks.

The first release candidate is going to be tagged tomorrow, so if you
have *anything*, it's worth publishing it now.  If not, you still have
time until the final release in a couple of weeks.

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/
 Are you not unsure you want to delete Firefox?
       [Not unsure]     [Not not unsure]    [Cancel]
                   http://smylers.hates-software.com/2008/01/03/566e45b2.html

---

From: Domenico Sgarbossa <[email-masked]>
Date: Mon, 26 Sep 2022 07:45:13 +0000 (UTC)

hmmm there's something I don't understand!
I download release 15 beta 4 from https://github.com/postgres/postgres/releases/tag/REL_15_BETA4 and ALL the italian PO files are ok.
So it seems there's nothing to do... probably I'm not looking at the right place.
could you tell me where can I find the missing translations?
Thanks

Il domenica 25 settembre 2022 21:44:25 CEST, Alvaro Herrera <[email-masked]> ha scritto:

---

From: "Pavlo Golub" <[email-masked]>
Date: Mon, 26 Sep 2022 08:04:33 +0000

>could you tell me where can I find the missing translations?
AFAIK only translated string get into the sources, so yes, you won't 
notice the missing ones.

To download the .pot files for work you should use 
https://babel.postgresql.org/

Kind Regards

>-- Álvaro Herrera              48°01'N 7°57'E  —  https://www.EnterpriseDB.com/

---

From: Holger Jakobs <[email-masked]>
Date: Mon, 26 Sep 2022 10:10:52 +0200

Am 26.09.22 um 10:04 schrieb Pavlo Golub:
>> I download release 15 beta 4 from 
>> https://github.com/postgres/postgres/releases/tag/REL_15_BETA4 and 
>> ALL the italian PO files are ok.
>>       [Not unsure]    [Not not unsure]    [Cancel] Tr
Try

postgresql-15beta4/src/backend/po$ grep -c msgstr *.po|sort -t: -k2n

and you will see how many strings of the backend have been translated to 
the languages. Ideally, all numbers would be identical, so 100% of 
strings would have been translated.

Of course there are more directories containing message catalog files.

  /backend/po
  /interfaces/ecpg/ecpglib/po
  /interfaces/ecpg/preproc/po
  /interfaces/libpq/po
  /pl/plperl/po
  /pl/plpgsql/src/po
  /pl/plpython/po
  /pl/tcl/po

Kind Regards,

Holger

-- 
Holger Jakobs, Bergisch Gladbach, Tel. +49-178-9759012

---

From: Peter Eisentraut <[email-masked]>
Date: Mon, 26 Sep 2022 13:35:40 +0200

> So it seems there's nothing to do... probably I'm not looking at the right place.

We drop incomplete translations at RC time, which I just did, so if you 
look again at the REL_15_STABLE HEAD, you will see some are gone now.

---

From: Domenico Sgarbossa <[email-masked]>
Date: Mon, 26 Sep 2022 13:39:48 +0200

I found out correct files in https://babel.postgresql.org/

Il 26 set 2022 13:35, Peter Eisentraut <[email-masked]> ha scritto:

---

From: Thom Brown <[email-masked]>
Date: Thu, 29 Sep 2022 13:56:19 +0100

> look again at the REL_15_STABLE HEAD, you will see some are gone now.

Does this mean it's now too late to get those dropped translations
reinstated prior to final release?  Or does this only give an
indication of what will happen if it remains this way?

---

From: Álvaro Herrera <[email-masked]>
Date: Thu, 29 Sep 2022 15:55:45 +0200

On Thu, Sep 29, 2022, at 2:56 PM, Thom Brown wrote:
>  now.

You can still contribute translations, and need only get past the 80% for each file in order to get it included. What is certain is that if nobody does anything, then it won't be included. Due date is Sunday the 9th.

---

From: Thom Brown <[email-masked]>
Date: Thu, 29 Sep 2022 15:16:38 +0100

> You can still contribute translations, and need only get past the 80% for each file in order to get it included. What is certain is that if nobody does anything, then it won't be included. Due date…

Domenico, will you be able to get the Italian translations completed
and submitted prior to that date?

-- 
Thom

---

From: Álvaro Herrera <[email-masked]>
Date: Thu, 29 Sep 2022 17:28:54 +0200

> and submitted prior to that date?

Note that "completed" means 80% of the total, minimum.  Taking the
server message catalog ("postgres") as a reference, that's currently at
78% for Italian, so you only need to add about 114 extra translations to
it so that it is included.  It is not a *huge* effort.  Of course,
getting it to 100% is much better.  The other catalogs are much smaller;
the only worrisome one is pg_dump because it's only 25% done, so you'd
need to work a lot to get it yellow in the table.

-- 
Álvaro Herrera        Breisgau, Deutschland  —  https://www.EnterpriseDB.com/
"Nadie está tan esclavizado como el que se cree libre no siéndolo" (Goethe)

---

From: Thom Brown <[email-masked]>
Date: Thu, 29 Sep 2022 16:30:48 +0100

> need to work a lot to get it yellow in the table.

Yes, in this case I saw the low-hanging fruit as getting the Italian
translation for Postgres over the 80% line.  Anything else is a
nice-to-have.

-- 
Thom

---

From: Domenico Sgarbossa <[email-masked]>
Date: Thu, 29 Sep 2022 15:39:45 +0000 (UTC)

I'm working hard in spare time to achive at least 80%!
I downloaded source files from https://babel.postgresql.org/ ... not to blame other people job but i found out a lot of garbage in those files.. 
my goal would be have at least 80% for every files before Sunday 9 October

Il giovedì 29 settembre 2022 17:31:19 CEST, Thom Brown <[email-masked]> ha scritto: 

-- 
Thom

---

From: Domenico Sgarbossa <[email-masked]>
Date: Thu, 6 Oct 2022 15:16:53 +0000 (UTC)

Hi, 
in attachment the files translated. 
All files are 100% traslated except the main file (postgres-it.po) which is 88% translated.
Maybe I could improve translation of this last file, which is the due date before commit?

thanks
Domenico

-- 
Thom

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 7 Oct 2022 08:22:16 +0200

> Maybe I could improve translation of this last file, which is the due date before commit?

Thank you for this work.  Could you please go through this one more time 
and check that all the --help output is correctly aligned.  Right now it 
looks all over the place.

We can still add translations after the 15.0 release, so there is no 
need to rush.

(Also, update the Project-Id-Version: header to include the new major 
version.)

---

From: Domenico Sgarbossa <[email-masked]>
Date: Fri, 7 Oct 2022 07:10:31 +0000 (UTC)

Ok,  I'll go through! 
I would suspect that the problem's of alignment should arise, sorry for that :-(
To be honest looking at the original label I cannot understand if rules are defined for that case..
could you give me some hints about that?

Thanks

Il venerdì 7 ottobre 2022 08:22:31 CEST, Peter Eisentraut <[email-masked]> ha scritto:

---

From: Álvaro Herrera <[email-masked]>
Date: Tue, 11 Oct 2022 18:07:31 +0200

> could you give me some hints about that?

There are no strict rules.  Just run each of the programs with the
--help option, and make sure that the output looks reasonable.

Some translators stick to 80 characters per line (splitting the line if 
too long), others let lines run long.  Most keep the same alignment
column as in the original language, but this is not a requirement
either.

psql also has:
psql --help=variables
psql --help=commands
I'm not aware of others.

Spanish has quite a mess, I now realize :-(

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/
"Las cosas son buenas o malas segun las hace nuestra opinión" (Lisias)

---

From: Peter Eisentraut <[email-masked]>
Date: Wed, 12 Oct 2022 08:02:22 +0200

> Spanish has quite a mess, I now realize :-(

I have for a long long time wanted to create some kind of API to produce 
two-column aligned output automatically.  Maybe someone wants to give it 
a try.

---

From: Domenico Sgarbossa <[email-masked]>
Date: Sun, 30 Oct 2022 17:54:58 +0000 (UTC)

Hi all,
here main PO file fully translated

Bye
Domenico

Il mercoledì 12 ottobre 2022 08:02:34 CEST, Peter Eisentraut <[email-masked]> ha scritto:

---

From: Thom Brown <[email-masked]>
Date: Wed, 2 Nov 2022 12:36:30 +0000

On Sun, 30 Oct 2022, 17:55 Domenico Sgarbossa, <[email-masked]> wrote:

Hi all,

Thanks for completing all those translations!

Thom

---

From: Peter Eisentraut <[email-masked]>
Date: Thu, 3 Nov 2022 18:14:36 -0400

> here main PO file fully translated

committed

---

From: Álvaro Herrera <[email-masked]>
Date: Fri, 4 Nov 2022 12:47:03 +0100

> Maybe I could improve translation of this last file, which is the due date before commit?

I have committed these other files now, but please do have a look at the
alignment of the --help output.