Subject: Typo in fr.po

From: Kirill Reshke <[email-masked]>
Date: Wed, 11 Sep 2024 01:40:52 +0500

While reading & grepping sources, found:

#~ "Synchronized snapshots are not supported on standby servers.\n"
 .....
#~ "Les snapshots synchronisés ne sont pas supportés sur les serveurs
de stadby.\n"

The last word should be `standby.` ?

-- 
Best regards,
Kirill Reshke

---

From: Alexander Lakhin <[email-masked]>
Date: Wed, 11 Sep 2024 06:00:00 +0300

Hello,

> The last word should be `standby.` ?

That msgstr line marked with "#", that is that entry is obsolete [1].

I could not find any clear typos in the French translation, but with very
helpful chkpos.py [2] (I can share the python3-compatible version I use)
from Daniele Varrazzo, I've discovered:
ERROR SuffixWhitespace failed in initdb.po: match failed
#: initdb.c:1086
#, c-format
msgid "selecting dynamic shared memory implementation ... "
msgstr "sélection de l'implémentation de la mémoire partagée dynamique..."

ERROR SuffixWhitespace failed in initdb.po: match failed
#: initdb.c:1481
#, c-format
msgid "running bootstrap script ... "
msgstr "lancement du script bootstrap..."

ERROR LongOption failed in initdb.po: option don't match
#: initdb.c:2465
#, c-format
msgid ""
"      --builtin-locale=LOCALE\n"
"                            set builtin locale name for new databases\n"
msgstr ""
"      --builtin-provider=LOCALE\n"
"                               initialise le fournisseur de locale natif pour\n"
"                               les nouvelles bases de données\n"

ERROR LongOption failed in initdb.po: option don't match
#: initdb.c:2477
#, c-format
msgid ""
"  -c, --set NAME=VALUE      override default setting for server parameter\n"
msgstr ""
"  -c NOM=VALEUR      surcharge la configuration par défaut d'un paramètre "
"serveur\n"

ERROR LongOption failed in initdb.po: option don't match
#: initdb.c:2481
#, c-format
msgid "  -n, --no-clean            do not clean up after errors\n"
msgstr "  -n, --noclean                ne nettoie pas après des erreurs\n"

ERROR LongOption failed in initdb.po: option don't match
#: initdb.c:2482
#, c-format
msgid ""
"  -N, --no-sync             do not wait for changes to be written safely to "
"disk\n"
msgstr ""
"  -N, --nosync                 n'attend pas que les modifications soient\n"
"                               proprement écrites sur disque\n"

ERROR PrefixWhitespace failed in initdb.po: match failed
#: initdb.c:2483
#, c-format
msgid "      --no-instructions     do not print instructions for next steps\n"
msgstr ""
"  --no-instructions            n'affiche pas les instructions des prochaines\n"
"                               étapes\n"

ERROR PrefixWhitespace failed in initdb.po: match failed
#: initdb.c:2627
#, c-format
msgid "  default collation: %s\n"
msgstr "collation par défaut : %s\n"

(initdb is not the only one, there are such errors in other .po files too.)

[1] https://www.gnu.org/software/gettext/manual/html_node/Obsolete-Entries.html
[2] https://github.com/dvarrazzo/postgresql-it/blob/master/tools/chkpos.py

Best regards,
Alexander

---

From: Guillaume Lelarge <[email-masked]>
Date: Wed, 11 Sep 2024 08:12:31 +0200

Hi,

Le mer. 11 sept. 2024 à 05:00, Alexander Lakhin <[email-masked]> a
écrit :

> [1]
> https://www.gnu.org/software/gettext/manual/html_node/Obsolete-Entries.html
I had no idea such a tool existed. I'll use it for my translations and fix
what needs to be fixed.

Thanks.

-- 
Guillaume.