Subject: Some deleted GUCs are still referred to

From: Peter Smith <[email-masked]>
Date: Thu, 9 Nov 2023 10:51:06 +1100

Hi,

I happened to notice that some GUC names "max_fsm_pages" and
"max_fsm_relations" are still mentioned in these translation files
(from the REL_16_1 source zip)

src\backend\po\fr.po
src\backend\po\tr.po

~~

Should those be removed?

There was a commit [1] that said these all traces of those GUCs had
been eliminated.

======

[1] https://github.com/postgres/postgres/commit/15c121b3ed7eb2f290e19533e41ccca734d23574#diff-65c699b5d467081e780d255ea0ed7d720b5bca2427e300f9fd0776bffe51560a

Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Daniel Gustafsson <[email-masked]>
Date: Thu, 9 Nov 2023 10:12:03 +0100

> On 9 Nov 2023, at 00:51, Peter Smith <[email-masked]> wrote:
> 
> Hi,
> 

These mentions are only in comments and not in actual translations, so I don't
think they risk causing any issues.

 $ git grep max_fsm_ |cut -d":" -f 2 |grep -v "^#" | wc -l
       0

I don't know enough about the translation workflow to know how these comments
are handled, sending this to pgsql-translators@ might be a better way to reach
the authors working on this.

> There was a commit [1] that said these all traces of those GUCs had

Translations are managed in an external repo and synced with the main repo at
intervals, so such a commit couldn't have updated the master translation work
files anyways.

--
Daniel Gustafsson

---

From: Peter Smith <[email-masked]>
Date: Tue, 14 Nov 2023 10:32:16 +1100

> the authors working on this.

Thanks for the advice. Done that.

======
Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Peter Smith <[email-masked]>
Date: Wed, 15 Nov 2023 12:20:10 +1100

FYI.

======
Kind Regards,
Peter Smith.
Fujitsu Australia

---------- Forwarded message ---------
From: Daniel Gustafsson <[email-masked]>
Date: Thu, Nov 9, 2023 at 8:12 PM
Subject: Re: Some deleted GUCs are still referred to
To: Peter Smith <[email-masked]>
Cc: PostgreSQL Hackers <[email-masked]>

--
Daniel Gustafsson