Subject: jp.po file mistakes on REL_17_STABLE branch

From: "Aya Iwata (Fujitsu)" <[email-masked]>
Date: Fri, 31 Jan 2025 14:10:17 +0000

Hi,

I found some ja.po file mistakes on REL_17_STABLE branch.
This issues were originally found by Yadav, Siddharth san. 

Issue Breakdown:
1. Added Messages
 
• File: src/bin/psql/po/ja.po
• Message:
  Issue: This message was added in the translation update commit (6bf5bf11c39) to the psql/po/ja.po file[1], but it is not present in the actual source code of OSS[2]. 

#: describe.c:3080
msgid "Not-null constraints:"
msgstr "非NULL制約:"

2. Deleted Messages
• File: src/bin/psql/po/ja.po
• Message:
  Issue: This message was marked as deleted in the translation update commit (6bf5bf11c39) in the psql/po/ja.po file[3]. However, it is still present in the actual OSS source code[4].

#: ../../port/user.c:43 ../../port/user.c:79
#, c-format
msgid "could not look up local user ID %d: %s"
msgstr "ローカルユーザーID %dの参照に失敗しました: %s"

3. Modified Messages
• File: src/backend/po/ja.po
• Message:
   Issue: The message was marked as modified in the translation update commit[5], but the original message in the OSS source code has not been changed[6].

#: access/transam/xlog.c:4406 access/transam/xlog.c:4416
#, c-format
- msgid "The database cluster was initialized with CATALOG_VERSION_NO %d, but the server was compiled with CATALOG_VERSION_NO %d."
- msgstr "データベースクラスタは CATALOG_VERSION_NO %d で初期化されましたが、サーバーは CATALOG_VERSION_NO %d でコンパイルされています。"
+ msgid "The database cluster was initialized with %s %d, but the server was compiled with %s %d."
+ msgstr "データベースクラスタは %s  %d で初期化されましたが、サーバーは %s  %d でコンパイルされています。"

I have heard that there may be other similar issues.

[1] https://github.com/postgres/postgres/blob/REL_17_STABLE/src/bin/psql/po/ja.po#L1686
[2] https://github.com/postgres/postgres/blob/REL_17_STABLE/src/bin/psql/describe.c
[3] https://github.com/postgres/postgres/commit/6bf5bf11c3944886225778790bf35aaff3b12a34#diff-9903b5f122043fc1201f4b8f1a0e3ff14d01869464b61369bfa9a55c856c8d57L203
[4] https://github.com/postgres/postgres/blob/REL_17_STABLE/src/port/user.c#L43 , https://github.com/postgres/postgres/blob/REL_17_STABLE/src/port/user.c#L79
[5] https://github.com/postgres/postgres/blob/REL_17_STABLE/src/backend/po/ja.po#L2315
[6] https://github.com/postgres/postgres/blob/REL_17_STABLE/src/backend/access/transam/xlog.c#L4400

Best regards,
Aya Iwata
Fujitsu

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 7 Feb 2025 09:19:47 +0100

Hi,

These all look like standard issues that arise as the source code 
changes and in some cases some patches in the source code were reverted.

You can download the current translation files from 
https://babel.postgresql.org/, fill in the missing strings, and delete 
obsolete ones, and send them in.

Thanks.

---

From: Álvaro Herrera <[email-masked]>
Date: Fri, 7 Feb 2025 10:21:57 +0100

> obsolete ones, and send them in.

Note that you don't have to search for obsolete messages specifically;
the message extraction system puts them aside at the end of each file.
Those lines start with #~ and you can just remove them.

-- 
Álvaro Herrera         PostgreSQL Developer  —  https://www.EnterpriseDB.com/