Subject: Re: DNS: mirrors?

From: "Magnus Hagander" <[email-masked]>
Date: Sat, 21 Jan 2006 10:33:19 +0100

> > Of these we have:
> > ns1.pgadmin.org and ns2.pgadmin.org - don't resolve at all. 
> Changed or 
> > should be removed?
> 
> 'k, where are ns{1,2}.pgadmin.org being used?

This whole thing is about the mirrors.postgresql.org zone.

> > Anyway. If I can get confirmation on how the above is 
> supposed to be, 
> > I'll fix it up ASAP.
> 
> 'k, I just did a major overhaul of our DNS this month ... 
> 200.46.204.2 was getting overloaded, and there was no easy 
> way to move things around, so I put the DNS servers on a 
> floating IP (the IP doesn't change, it can just float between 
> servers) instead of tying it to a specific server ...
> 
> So, the IPs should all be:
> 
>    ?column?   |      data
> -------------+----------------
>   ns4.hub.org | 200.46.208.251
>   ns.hub.org  | 200.46.204.13
>   ns2.hub.org | 66.98.250.36
>   ns3.hub.org | 200.46.204.254
> (4 rows)

Ok. Will update.

> Everything is in a bind-dlz database right now (except 
> postgresql.org itself, since I haven't quite figured out a 
> clean way of doing that yet, since its generated based on 
> other data sources) ...
> 
> Primaary is 200.46.204.13, as the others are all slony slaves 
> from it ...

Uh, I hope it's not set up like that for mirrors.postgresql.org? If so,
it's very much broken. It needs to be set up with them all as slaves off
the blind primary, the way it used to be.

Can you check and confirm for that specific zone?

//Magnus

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 21 Jan 2006 11:33:22 -0400 (AST)

> Can you check and confirm for that specific zone?

'k, I can't see anything about ns1.pgadmin.org in teh zone file:

www             IN      CNAME   static.mirrors.postgresql.org.
mirrors IN      NS      ns.hub.org.
mirrors IN      NS      ns2.hub.org.
mirrors IN      NS      ns3.hub.org.
mirrors IN      NS      ns-1.sollentuna.net.
mirrors IN      NS      ns-a.lerctr.org.
mirrors IN      NS      ns-b.lerctr.org.

I'm obviously missing something here ...

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664