Subject: Re: svr2/unionfs

From: "Dave Page" <[email-masked]>
Date: Tue, 29 Nov 2005 16:52:51 -0000

> -----Original Message-----
> From: Marc G. Fournier [mailto:[email-masked]] 
> Sent: 29 November 2005 16:48
> To: Dave Page
> Cc: Magnus Hagander; Marc G. Fournier; [email-masked]
> Subject: RE: svr2/unionfs
> 
> On Tue, 29 Nov 2005, Dave Page wrote:
> 
> > Hmm, that's a good point. Marc; any idea how long the 
> downtime is likely 
> > to be? I'm not sure what the best way to redirect the 
> clients will be 
> > unless we temporarily write a static version of the few 
> hundred or so 
> > mirror selection pages.
> 
> So, why not just create a second wwwmaster, that is 
> templateless ... we'll 
> call it wwwmaster2.postgresql.org for testing purposes ... 
> then, once we 
> know its all working, we shutdown the old and restart the new was 
> wwwmaster?

That's a good idea, except it'll take a fair bit of setup I imagine. Can
we just copy svr2 over a copy of the template and bring that up as
wwwmaster2 for testing? I don't think we need to worry about cleanly
installing the VM at this stage, just eliminating the unionfs.

Gavin - any chance we can temporarily get an additional IP address if
that's a possibility?

Regards, Dave

---

From: "Gavin M. Roy" <[email-masked]>
Date: Tue, 29 Nov 2005 09:37:36 -0800

Of course.  I believe this is on the same subnet:

65.19.161.70/255.255.255.128/gw 65.191.61.1

Gavin

> Gavin - any chance we can temporarily get an additional IP address if

Gavin M. Roy
800 Pound Gorilla
[email-masked]

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 29 Nov 2005 21:29:24 -0400 (AST)

> installing the VM at this stage, just eliminating the unionfs.

If we're just going to do that, then it does make it alot simplier ... but 
don't worry about the wwwmaster2 stage, since you aren't changing 
anything, you are just merging the file systems.

cd <template root>
find . -print | cpio -pdma /vm/186/svr2.postgresql.org.n
shutdown svr2
cd /vm/186/svr2.postgresql.org
find . -print | cpio -pduma ../svr2.postgresql.org.n
cd ..
mv svr2.postgresql.org svr2.postgresql.org.orig
mv svr2.postgresql.org.n svr2.postgresql.org

change template id in /usr/local/etc/jail.conf to 7 (I believe that 
start_jail on that server recognizes that as "do not mount a template") 
and then restart ...

You haven't changed any applications, or versions, or anything ... and, in 
fact, you still have all the ports information in /var/db/pkg, so you can 
remove ports as desired (ie. all the java stuff) ...

for this, I wouldn't run a duplicate in tandem, that's just more work then 
this requires ...

  ----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664