Subject: Re: svr2/unionfs

From: "Dave Page" <[email-masked]>
Date: Mon, 28 Nov 2005 11:04:45 -0000

> -----Original Message-----
> From: Marc G. Fournier [mailto:[email-masked]] 
> Sent: 27 November 2005 23:00
> To: Dave Page
> Cc: [email-masked]
> Subject: Re: svr2/unionfs
> 
> On Sun, 27 Nov 2005, Dave Page wrote:
> 
> > Hi Marc,
> >
> > How easy would it be to get rid of the unionfs stuff on 
> svr2/borg? Given
> > that there is only the one VM, can the vserver just be 
> copied over the
> > template?
> 
> the ones we've been doing, and what we'll be doing with teh 
> dev vserver 
> tonight, is we copy over a clean, base template (ie. imap, 
> postfix and 
> vanilla apache) and then re-add the various applications over 
> top of it 
> ... that way it doesn't have any of the extra trash installed ...
> 
> In theory, you could do that where you just copy it over the template 
> itself ...
> 
> If you want to go the clean route, though, what I'm doing is:
> 
> cp fresh base template
> shut down old vServer
> rm various top level directories that can be safely removed
>         - compat, sys, kernel, dev, modules, proc, tmp
> cd usr; find . -depth -type d -delete
>         - clears out the 'ghost directories that unionfs creates
> cd ..
> find . -print | cpio -pduma ../<new vserver hierarchy>
> 
> and then restart ...
> 
> for dev/lists, I'll disable postfix from starting up on 
> restart, since I 
> need to re-install the perl modules for majordomo2 ... for wwwmaster, 
> you'd have to worry about making sure the appropriate php modules are 
> installed ...
> 
> the 'painful ones' are doing the vServers with Java 
> installed, since you 
> have to build it all from scratch, which takes a good long 
> while ... but 
> the rest are fairly quick/easy ...

Cool. So when can you do it? :-p

Regards, Dave.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 28 Nov 2005 10:46:04 -0400 (AST)

> Cool. So when can you do it? :-p

Not today :)

If you want to send me a reminder, how about Wednesday?

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664