Subject: Re: [Fwd: [BUGS] BUG #2560: Web page documentation hard

From: "Dave Page" <[email-masked]>
Date: Wed, 2 Aug 2006 21:39:57 +0100

-----Original Message-----
From: "Tom Lane" <[email-masked]>
To: "Richard Huxton" <[email-masked]>
Cc: "Robert Bernier" <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: 02/08/06 20:30
Subject: Re: [pgsql-www] [Fwd: [BUGS] BUG #2560: Web page documentation hard 

> But what strikes me is the idea of teaching the search engine not to
> ignore stopwords that are marked as <indexterm>'s ...

We tell it what to ignore, not the other way round. Besides, the problem as I understood it was that a search for 'IN' returns virtually every page (as one might expect) which is little help when looking for IN the keyword.

Regards, Dave

---

From: Tom Lane <[email-masked]>
Date: Wed, 02 Aug 2006 16:43:09 -0400

> We tell it what to ignore, not the other way round. Besides, the problem as I understood it was that a search for 'IN' returns virtually every page (as one might expect) which is little help when l…

Right, so half of the problem is that IN should be considered a stopword
and isn't.  But after we fix that, it won't be found anywhere.  I
suggest that we want the search to find the pages on which IN (or any
other stopword) appears as an <indexterm>, and not elsewhere.

			regards, tom lane