Subject: Replacing @ with " at "

From: Devrim GUNDUZ <[email-masked]>
Date: Fri, 5 Dec 2003 11:27:29 +0200 (EET)

Hi,

I edited buildnews.php and buildevents.php to replace @ signs with " at " 
(omitting the quotes) to avoid spam, as proposed by Christopher 
Kings-Lynne. Dave, should it be committed to CVS?

I saw something on index.php; but I'm not sure that it works:

 ereg_replace("@", "&#064;", pg_result($rs, $x, "posted_by"))

Regards,
- -- 
Devrim GUNDUZ
[email-masked]				[email-masked] 
			http://www.TDMSoft.com
			http://www.gunduz.org

---

From: "Dave Page" <[email-masked]>
Date: Fri, 5 Dec 2003 11:46:26 -0000

> -----Original Message-----
> From: Devrim GUNDUZ [mailto:[email-masked]] 
> Sent: 05 December 2003 11:21
> To: Dave Page
> Cc: PostgreSQL WWW Mailing List
> Subject: Re: [pgsql-www] Replacing @ with " at "
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> Hi,
> 
> On Fri, 5 Dec 2003, Dave Page wrote:
> 
> > That was done by Greg Sabino Mullane
> 
> hmm. I've edited index.php, and it seems ok now.
> 
> http://www.postgresql.org/index.php
> 
> I've also edited news.php and event.php. Dave, could you 
> please commit all three files to CVS?

Thanks, committed.

> BTW: index.php and index.html are not in sync for hours. IS 
> there a problem?

I just ran it manually and it went OK.

BTW; I have now added a build/buildpage script to rebuild just a single
page. 

Usage:

$ build/buildpage /index

Unless you are root it'll fail to do the chown at the end, but it should
build OK.

Regards, Dave.