Subject: Re: [webmaster] online demonstration against EU Software Patents

From: "Dave Page" <[email-masked]>
Date: Sat, 10 Apr 2004 20:20:37 +0100

> -----Original Message-----
> From: Justin Clift [mailto:[email-masked]] 
>
> Hi Dave,
> 
> Would it be ok for us to do something more prominent?  
> Preferably copy-n-paste the KDE page's warning to the top of 
> the PG homepage, just above the News and Events.
> 
> Ensuring patent coverage isn't widened is in the direct 
> interests of PostgreSQL.

Hi Justin,

Agreed - what do the rest of the web group think; anyone got any better
wording? Any objections?

Regards, Dave.

---

From: Robert Treat <[email-masked]>
Date: Sun, 11 Apr 2004 17:04:25 -0400

> Agreed - what do the rest of the web group think; anyone got any better

Honestly? I'd be hesitant to put the project into the middle of any political 
discussion.  Someone thinking about using postgresql for business might see 
the banners and decide they dont want to be involved with us at all...

I'd probably debate it further if I was actually for software patents...

Robert Treat
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sun, 11 Apr 2004 18:05:18 -0300 (ADT)

> I'd probably debate it further if I was actually for software patents...

Just curious here, but aren't software patents already an issue in the US?
I know I've been seeing several going around, or, at least, I believe I
have ... if so, how does this extenting to the EU make any difference?

Myself, I agree with Robert here about being in the middle of things, but
only if I'm correct in that this is already a problem in the US that isn't
going to make anything worse/better by the EU having/not having it ...

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Robert Treat <[email-masked]>
Date: Sun, 11 Apr 2004 20:08:33 -0400

On Sunday 11 April 2004 17:05, Marc G. Fournier wrote:
> > Honestly? I'd be hesitant to put the project into the middle of any
> > political discussion.  Someone thinking about using postgresql for
> > business might see the banners and decide they dont want to be involved
> > with us at all...
> >

I think the deal is that those in Europe aren't currently subject to software 
patent litigation even if it violates US law.  Further, some of the 
interpretations of the laws being proposed in Europe are fairly draconian, 
and could put more cautious open source distributors "out of business" so to 
speak.  check out http://www.knopper.net/knoppix/index-en.html for some 
informational links.

Robert Treat

---

From: "Dave Page" <[email-masked]>
Date: Mon, 12 Apr 2004 10:26:08 +0100 (BST)

It's rumoured that Robert Treat once said:
>
> I think the deal is that those in Europe aren't currently subject to
> software  patent litigation even if it violates US law.  Further, some
> of the  interpretations of the laws being proposed in Europe are fairly
> draconian,  and could put more cautious open source distributors "out
> of business" so to  speak.  check out
> http://www.knopper.net/knoppix/index-en.html for some  informational
> links.

Yes, that's about right - in fact the link at the bottom of that page
leads to the proper Knoppix homepage which mentions even simple common
features like progress bars and scrollable windows being under threat. The
problem isn't even whether on not a project actually infringes a patent
anyway though - just checking whether on not it does can cost a huge
amount of money, so an unscrupulous corporate could put a project out of
business with an infringement claim that warrants further investigation,
whether or not the claim is valid.
As for the US issue - my understanding is that in the US you can only
patent complex software processes and concepts, whereas in the EU you will
be able to patent simple 'things' such as UI controls.
Regards, Dave

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 12 Apr 2004 05:34:25 -0400 (EDT)

> be able to patent simple 'things' such as UI controls.

Here is a scarey article talking about patents and generating patent
revenue:

	http://news.com.com/2100-1014_3-5189747.html?tag=nefd.top

Dave is right that just checking on patents can make software
development impossible for all but the largest organization.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Justin Clift <[email-masked]>
Date: Mon, 12 Apr 2004 18:23:03 +0800

Bruce Momjian wrote:
<snip>
> development impossible for all but the largest organization.

Cool.  Does this mean we're ok to make the warning on the home page more 
prominent?

:)

Regards and best wishes,

Justin Clift

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Mon, 12 Apr 2004 11:11:05 -0000

> Cool.  Does this mean we're ok to make the warning on the home
> page more prominent?
 
More prominent than the ugly, neon green animated Pac-man like thing
currently on the home page? What percentage of the people reading
the page are really going to be able to "come to Brussels?" I vote
for removing it and keeping the project as apolitical as possible.
 
- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200404120710

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 12 Apr 2004 07:33:52 -0400 (EDT)

> Cool.  Does this mean we're ok to make the warning on the home page more 

No, it already looks pretty prominenty to me.

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 12 Apr 2004 07:34:29 -0400 (EDT)

Greg Sabino Mullane wrote:
[ There is text before PGP section. ]
[ PGP not available, raw data follows ]
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>  
>  

Good description, and suggestion.

---

From: Justin Clift <[email-masked]>
Date: Mon, 12 Apr 2004 20:50:02 +0800

> for removing it and keeping the project as apolitical as possible.

It still raises people's awareness, regardless of whether they can get 
to Brussels or not.

This is not really a political issue.  It's looking after our own long 
term interests.

:-)

Regards and best wishes,

Justin Clift

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 12 Apr 2004 10:03:12 -0300 (ADT)

> This is not really a political issue.  It's looking after our own long

Nobody has yet mentioned how this is the case ... how would such a patent
affect us?  For instance, there is no EU corporate entity that anyone
could claim copyright infringement against, so there is nobody to 'tie up
in the courts' ... would this give someone in the EU the ability to take
companyA *using* PostgreSQL to court?

----

---

From: "Andreas Grabmueller" <[email-masked]>
Date: Mon, 12 Apr 2004 15:05:55 +0200

Keep the project apolitical? What happens if someone patents "A software that stores and manages data" - PostgreSQL will then be illegal here in Europe - who should pay the license fees? And this is exactly the type of patent we are talking about (and that kind of patents already exist here in Germany, they just are not legal yet).

Mit freundlichen Grüßen
Andreas Grabmüller

----- Original-Nachricht -----
Von: "Greg Sabino Mullane" <[email-masked]>
An: [email-masked]
Datum: Monday, April 12, 2004 01:11 PM
Betreff: [pgsql-www] [webmaster] online demonstration against EU Software

> -----BEGIN PGP SIGNATURE-----
>  
> iD8DBQFAenmDvJuQZxSWSsgRAj0tAKCE7mTm7ebLRTpnG+PtwYzZgYReVQCfXJNF
> IE4kM/xght/dY9pLEkbxgg8=
> =6mVd
> -----END PGP SIGNATURE-----
> 
> 
> 
> ---------------------------(end of broadcast)---------------------------
> TIP 1: subscribe and unsubscribe commands go to [email-masked]

--
LetzPlay.de
| Freemail:       http://www.letzplay.de/mail
| Forenhosting: http://www.letzplay.de/foren
>From [email-masked]  Mon Apr 12 10:12:13 2004
To: [email-masked], [email-masked]
Subject: Re: [webmaster] online demonstration against EU Software
Reply-To: <[email-masked]>
From: "Andreas Grabmueller" <[email-masked]>
Cc: [email-masked], [email-masked]
Date: Mon, 12 Apr 2004 15:08:57 +0200

> companyA *using* PostgreSQL to court?

I'm not sure if this is the case. However, the distribution would be illegal. The biggest distributor in Germany is SuSE - and they would be no more able to distribute PostgreSQL (and many more things)...

Mit freundlichen Grüßen
Andreas Grabmüller

--
LetzPlay.de
| Freemail:       http://www.letzplay.de/mail
| Forenhosting: http://www.letzplay.de/foren
>From [email-masked]  Mon Apr 12 10:25:32 2004
Date: Mon, 12 Apr 2004 10:25:35 -0300 (ADT)
From: "Marc G. Fournier" <[email-masked]>
To: Andreas Grabmueller <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: [webmaster] online demonstration against EU Software

On Mon, 12 Apr 2004, Andreas Grabmueller wrote:

> Keep the project apolitical? What happens if someone patents "A software
> that stores and manages data" - PostgreSQL will then be illegal here in
> Europe - who should pay the license fees? And this is exactly the type
> of patent we are talking about (and that kind of patents already exist
> here in Germany, they just are not legal yet).

'k, but such a broad patent would see ppl like Oracle, Sybase and several
other commercial vendors in court, no?  I can't see that sort of patent
holding up for very long ...

----

---

From: Robert Treat <[email-masked]>
Date: Mon, 12 Apr 2004 09:07:14 -0400

Would you guys feel better about

http://www.e-labs.org/patent_overload.gif

Robert Treat

---

From: Tom Lane <[email-masked]>
Date: Mon, 12 Apr 2004 09:42:41 -0400

>> This is not really a political issue.  It's looking after our own long

It certainly is a political issue, but I agree that it's in our long
term interests to worry about it.  Being apolitical in this situation
is unilateral disarmament: we can be as apolitical as we like, but
that's not going to stop the lawyers from putting us out of business.

"Marc G. Fournier" <[email-masked]> writes:
> affect us?

By making it illegal or dangerous for European software developers to
work on Postgres.

It doesn't take a lot of imagination to think that Microsoft is pushing
this (behind the scenes of course).  Bill Gates is on record as seeing
"cut off your opponent's air supply" as legitimate competitive behavior.
In this case the air supply he's hoping to cut off for open source is
the availability of developers.  If people are afraid to contribute at
all, or spend all their time researching patent issues instead of doing
productive coding, then open-source development dies.

			regards, tom lane

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Tue, 13 Apr 2004 00:50:20 -0000

> ...
 
* Can we replace the ad with something else? Anything else? The color
choices are horrible. The site is sad enough already (any word on the
new one anyone?)
 
* Who makes the decision of what goes on the site? Core? The -www list?
Marc? Is there a process?
 
* Why not at least have a "news item" that explains why the banner is
there, why people should be concerned, and what it might mean to
the PostgreSQL project. Asking people to click on a banner ad mentioning
Brussels is not going to entice many people to learn more.
 
- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200404122050

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 12 Apr 2004 21:59:21 -0300 (ADT)

> Marc? Is there a process?

Concensus where possible ... I'm not against putting it up, else I'd be
more vocal ... I'm just more curious as to potential impact on us if the
law does go through ...

----

---

From: "Dave Page" <[email-masked]>
Date: Tue, 13 Apr 2004 19:07:34 +0100 (BST)

It's rumoured that Greg Sabino Mullane once said:
> choices are horrible.

OK I appreciate that it wasn't the nicest banner, but did it have to get
changed for a 200KB one?!!?!
> The site is sad enough already

I didn't hear you screaming suggestions when I redesigned it - at the time
everyone who commented liked it.
Regards, Dave.

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Wed, 14 Apr 2004 11:45:54 -0000

> changed for a 200KB one?!!?!
 
Yeah, that one is a bit long to sit through.
 
> everyone who commented liked it.
 
Has it been redesigned? I thought we had a new version in the wings,
waiting for this, that, and the other. As far as helping out, I've
put in plenty of suggestions over time, and even joined the gborg
group (one of the few who did) to put my money where my mouth is.
My biggest suggestion for the site right now is to lose the fixed-width
table - it looks terrible to see the site constrained to a centered box
in the middle of the browser. Second biggest is to lose the
"Contact the Webmasters" box, which seems pointless and almost borders
on rude with the wording about ignoring requests.
 
- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200404140744